Opened 4 years ago

Closed 17 months ago

Last modified 17 months ago

#6339 closed defect (fixed)

Win32 build is failed when using ICL

Reported by: bifurcator Owned by:
Priority: important Component: avutil
Version: git-master Keywords: icl regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
Win32 build fails when using icl toolchain.

How to reproduce:
1) specify --toolchain=icl for ./configure
2) make falis in the following way

libavutil/utils.c(156): error: expected a ";"
          "fstenv %0 \n\t"

Attachments (1)

patchicl.diff (369 bytes ) - added by Carl Eugen Hoyos 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by Carl Eugen Hoyos, 4 years ago

Keywords: icl regression added
Priority: normalimportant
Version: unspecifiedgit-master

Apparently a regression since f5495c97

by Carl Eugen Hoyos, 4 years ago

Attachment: patchicl.diff added

comment:2 by Carl Eugen Hoyos, 4 years ago

Please test attached patch.

comment:3 by Balling, 17 months ago

Resolution: fixed
Status: newclosed
Last edited 17 months ago by Carl Eugen Hoyos (previous) (diff)

comment:4 by Carl Eugen Hoyos, 17 months ago

Component: build systemavutil
Note: See TracTickets for help on using tickets.