Opened 5 years ago

Closed 4 years ago

Last modified 3 years ago

#6265 closed defect (fixed)

cineform decoder output invalid alpha

Reported by: mvignali Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: cfhd alpha
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

Cineform RGBA 12b, doesn't have right alpha decoding

How to reproduce:
./ffmpeg -i /Users/martinvignali/Documents/ELEMENTS_DEV/CINEFORM/cineform_rgba_12b.mov -loglevel debug cineform_rgba_12b.png

Attachments (3)

cineform_rgba_12b.mov (1.4 MB ) - added by mvignali 5 years ago.
cineform rgba 12b from media encoder
cineform_rgba_12b_from_ffmpeg_quarter.png (500.4 KB ) - added by mvignali 5 years ago.
cineform_rgba_12b_export_from_ae_quarter.png (495.2 KB ) - added by mvignali 5 years ago.

Change History (7)

by mvignali, 5 years ago

Attachment: cineform_rgba_12b.mov added

cineform rgba 12b from media encoder

comment:1 by Carl Eugen Hoyos, 5 years ago

Keywords: cfhd added; cineform removed

How is the output supposed to look like?

comment:2 by mvignali, 5 years ago

I add two png (quarter resolution), to show the difference of output between ffmpeg and After Effects.

comment:3 by Carl Eugen Hoyos, 4 years ago

Resolution: fixed
Status: newclosed

Fixed by Gagandeep Singh in c64c97b972c7325a71440a352a7d541a8c92b2da

comment:4 by mkver, 3 years ago

This has reappeared. See #7886.

Note: See TracTickets for help on using tickets.