Opened 3 years ago

Closed 2 years ago

#5961 closed defect (needs_more_info)

Unable to push video to rtmp server if the input to ffmpeg is a sdp file

Reported by: santhoshv29 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: sdp
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have the sdp file and nginx rtmp server, for my application I am using ffmpeg which takes sdp as input and push to rtmp server.

The command I used is
ffmpeg -i s.sdp -c:v copy -f flv rtmp://127.0.0.1:1935/live/mystream

and the error I get is

ffmpeg version 2.0 Copyright (c) 2000-2013 the FFmpeg developers

built on Aug 16 2013 14:23:16 with gcc 4.1.2 (GCC) 20080704 (Red Hat 4.1.2-50)
configuration: --prefix=/opt/ffmpeg_build --extra-cflags='-I/opt/ffmpeg_build/include -I/opt/ffmpeg_build/include/freetype2 -static' --extra-ldflags='-L/opt/ffmpeg_build/lib -static' --bindir=/opt/ffmpeg/bin --extra-libs='-ldl -lfreetype -lpng12 -lz -lbz2' --enable-gpl --enable-nonfree --enable-libx264 --enable-libfreetype --disable-shared --enable-static
libavutil      52. 42.100 / 52. 42.100
libavcodec     55. 28.100 / 55. 28.100
libavformat    55. 13.102 / 55. 13.102
libavdevice    55.  3.100 / 55.  3.100
libavfilter     3. 82.100 /  3. 82.100
libswscale      2.  5.100 /  2.  5.100
libswresample   0. 17.103 /  0. 17.103
libpostproc    52.  3.100 / 52.  3.100

[sdp @ 0x1925de0] Could not find codec parameters for stream 0 (Video: h264): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
/opt/ffmpeg/s.sdp: could not find codec parameters

Please can someone help to resolve this.

Regards,
Santhosh

Change History (2)

comment:1 Changed 3 years ago by cehoyos

Please test current FFmpeg git head.

comment:2 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if the issue is reproducible with current FFmpeg git head and if you can explain how to reproduce the issue.

Note: See TracTickets for help on using tickets.