Opened 3 years ago

Closed 3 years ago

#5940 closed defect (fixed)

hls: hls_list_size breaks program_date_time

Reported by: ronag Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: hls
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

If using hls_list_size together with program_date_time the EXT-X-PROGRAM-DATE-TIME tags start to become wrong when segments are removed. initial_prog_date_time should probably be incremented by the duration of the segments removed.

This is because currently because when segments are removed their accumulated duration is no longer added to prog_date_time in https://github.com/FFmpeg/FFmpeg/blob/master/libavformat/hlsenc.c#L569

When removing a segment at https://github.com/FFmpeg/FFmpeg/blob/master/libavformat/hlsenc.c#L406 we should also increment the initial_prog_date_time by the duration of the removed segment.

Change History (1)

comment:1 Changed 3 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Your patch was (fixed and) applied as c0dc9df2cc6321155e8a7a2a6c66be54746e5c13

Note: See TracTickets for help on using tickets.