Opened 3 years ago

Closed 3 years ago

#5857 closed defect (fixed)

null pointer passed as argument in av_grow_packet()

Reported by: tsmith Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: ubsan regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
libavcodec/avpacket.c:142:32: runtime error: null pointer passed as argument 2, which is declared to never be null

How to reproduce:

% ffmpeg -f ivf -i <test_case> -f null -
ffmpeg version N-81721-g7447ec9 Copyright (c) 2000-2016 the FFmpeg developers
  built with clang version 3.8.0-2ubuntu3 (tags/RELEASE_380/final)
  configuration: --cc=clang --cxx=clang++ --disable-libxcb --disable-xlib --disable-logging --disable-ffprobe --disable-ffplay --disable-sdl --disable-ffserver --disable-doc --disable-pthreads --disable-network --disable-d3d11va --disable-dxva2 --disable-vaapi --disable-vda --disable-vdpau --disable-stripping --disable-runtime-cpudetect --disable-postproc --disable-securetransport --disable-iconv --disable-swscale --disable-avdevice --disable-videotoolbox --disable-everything --enable-encoder=wrapped_avframe --disable-lzma --enable-protocol='file,pipe' --enable-muxer=null --enable-demuxer=ivf --enable-parser=vp9 --enable-decoder=vp9 --disable-pic
  libavutil      55. 30.100 / 55. 30.100
  libavcodec     57. 57.101 / 57. 57.101
  libavformat    57. 50.100 / 57. 50.100
  libavfilter     6. 62.100 /  6. 62.100
  libswresample   2.  1.100 /  2.  1.100
st:0 has too large timebase, reducing
libavcodec/avpacket.c:142:32: runtime error: null pointer passed as argument 2, which is declared to never be null
/usr/include/string.h:43:28: note: nonnull attribute specified here
    #0 0x676273 in av_grow_packet libavcodec/avpacket.c:142:9
    #1 0x61f04a in append_packet_chunked libavformat/utils.c:239:15
    #2 0x606a25 in read_packet libavformat/ivfdec.c:75:11
    #3 0x623d51 in ff_read_packet libavformat/utils.c:766:15
    #4 0x62c868 in read_frame_internal libavformat/utils.c:1464:15
    #5 0x640e43 in avformat_find_stream_info libavformat/utils.c:3495:15
    #6 0x503eca in open_input_file ffmpeg_opt.c:1019:11
    #7 0x500e45 in open_files ffmpeg_opt.c:3091:15
    #8 0x50029a in ffmpeg_parse_options ffmpeg_opt.c:3128:11
    #9 0x5483c8 in main ffmpeg.c:4311:11
    #10 0x7f7a3422882f in __libc_start_main /build/glibc-GKVZIf/glibc-2.23/csu/../csu/libc-start.c:291
    #11 0x419858 in _start

Attachments (1)

test_case.ivf (21 bytes) - added by tsmith 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by tsmith

comment:1 Changed 3 years ago by cehoyos

  • Keywords regression added
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Regression since 2fe04630, fixed in c54eef46f990722ed65fd1ad1da3d0fc50806eb5, thank you for the report!

Note: See TracTickets for help on using tickets.