#5848 closed defect (needs_more_info)

when using h264_qsv gives an access violation on avcodec

Reported by: etomm Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: h264_qsv regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

It is impossible to use the h264_qsv encoder/decoder because it crashes with an Access Violation exception.

How to reproduce:
I downloaded the mp4 hd video from here as a test: http://youtubeinmp4.com/youtube.php?video=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DkXFcr6oy5dk

Using this command line it crashes instead of beginning the decoding/encoding.

ffmpeg.exe -fflags +genpts -c:v h264_qsv  -i file:"input.mp4" -map 0:0 -map 0:1 -map -0:s -codec:v:0 h264_qsv -force_key_frames "expr:gte(t,n_forced*5)" -vf "scale=trunc(min(max(iw\,ih*dar)\,720)/2)*2:trunc(ow/dar/2)*2" -copyts -avoid_negative_ts disabled -start_at_zero -preset 7 -look_ahead 0 -b:v 874413 -maxrate 874413 -bufsize 1748826 -vsync -1 -profile:v high -level 4.1 -map_metadata -1 -threads 0 -codec:a:0 copy -y "8a2fbee18db504f033392ec381ab57f5.mkv"

I am using Zeranoe builds. The last working build is the one built on ffmpeg-20160409-git-0c90b2e.

All the version fails the same way x86, x64, shared and static.

The machine is a Xen7 Windows Server 2012 R2 machine with the Intel Skylake HD 530 passed through.

Just to underline. It works with the April 9th build, and I know the QSV is working because Handbrakes works. So it is not a matter of Passthrough.

Change History (2)

comment:1 Changed 19 months ago by cehoyos

  • Keywords regression added; avcodec removed
  • Priority changed from critical to normal

Please compile yourself to get a version with debug symbols and provide a backtrace, disassembly and register dump as explained on https://ffmpeg.org/bugreports.html or report the crash on the Zeranoe forum.
And please use git bisect to find the change introducing the issue (or report to the Zeranoe forum).

comment:2 Changed 17 months ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.