Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5814 closed license violation (duplicate)

License violation - Synology NAS products

Reported by: patters Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I would like to report a violation of the GPL terms for FFmpeg. Synology (http://www.synology.com) manufactures Network Attached Storage devices based on the Linux operating system.

The company provides some outdated downloads of the open source software used in their many products at https://sourceforge.net/projects/dsgpl/files/Synology%20NAS%20GPL%20Source/

Synology ships their products with a Linux distribution called DSM (Disk Station Manager) which incorporates FFmpeg. FFmpeg is also used in several of Synology's own optional software packages such as Video Station, and Media Server. The company had used FFmpeg 2.0.2 for DSM version 5.2 but it has switched to FFmpeg 2.7.1 in DSM 6.0. Furthermore, Synology uses heavily modified versions of FFmpeg to enable the hardware encoding and decoding features of some of its dedicated hardware products - so called media transcoding NAS models (e.g. Intel Evansport SoC). Despite this heavy reliance on FFmpeg to sell its products as media-ready, Synology has not published source code since 2015. Source code to DSM 6.0 software components (first published in public beta in October 2015) has been withheld.

The GPL download page lists DSM 5.2 version "5564 branch" dated December 2015 (itself a lagged release) as the latest available source code for download, but this is eight months older than the latest major release "8451 branch". Since DSM 6.0 was a major new OS release, many of the FOSS components included in this Linux distribution were updated including FFmpeg. Package developers like me are entitled to access to this source code now, not 8 months later while Synology tries to obfuscate its software improvements from its commercial competitors. Synology chose to build on FOSS, so they must comply with the terms.

I raised a support request with Synology in April 2016, asking for the DSM 6.0 source code tarball and was given a brush-off - with them having the nerve to comment that there is no stipulation for when the sources must be published, and that they would be published at some later unspecified time.

Synology is making money off the hard work of the FFmpeg developers without abiding by the GPL licence obligations, which is unethical, unfair, and illegal. Please can you investigate.

More info here https://forum.synology.com/enu/viewtopic.php?f=223&t=120535
...including the exact wording of the brush-off I was given by Synology support.

As you can see from that forum thread, people have attempted to complain about other violations (e.g. Samba). Since repeated legitimate requests for compliance have gone unheeded, I think that a public shaming of the company on the main FFmpeg website would be appropriate.

Thank you

Change History (9)

comment:1 Changed 3 years ago by patters

Forgot to show the FFmpeg output from my own Synology system so you can see which licenses apply:

ffmpeg version 2.7.1 Copyright (c) 2000-2015 the FFmpeg developers

built with gcc 4.9.3 (crosstool-NG 1.20.0) 20150311 (prerelease)
configuration: --prefix=/usr --incdir='${prefix}/include/ffmpeg' --arch=i686 --target-os=linux --cross-prefix=/usr/local/i686-pc-linux-gnu/bin/i686-pc-linux-gnu- --enable-cross-compile --enable-optimizations --enable-pic --enable-gpl --enable-shared --disable-static --enable-version3 --enable-nonfree --enable-libfaac --enable-encoders --enable-pthreads --disable-bzlib --disable-protocol=rtp --disable-muxer=image2 --disable-muxer=image2pipe --disable-swscale-alpha --disable-ffserver --disable-ffplay --disable-devices --disable-bzlib --disable-altivec --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --disable-vaapi --disable-decoder=amrnb --disable-encoder=zmbv --disable-encoder=dca --disable-encoder=ac3 --disable-encoder=ac3_fixed --disable-encoder=eac3 --disable-decoder=dca --disable-decoder=eac3 --disable-decoder=truehd --cc=/usr/local/i686-pc-linux-gnu/bin/i686-pc-linux-gnu-ccache-gcc --enable-yasm --enable-libx264 --enable-encoder=libx264 --enable-libh264_smd --enable-smd --disable-filter=hqdn3d --extra-libs='-lgdl -losal -lpal -lsven -lismd_core -lismd_audio -lismd_viddec -lismd_videnc -lismd_vidpproc -lplatform_config -lffmpeg_plugin -ljson-c '
libavutil 54. 27.100 / 54. 27.100
libavcodec 56. 41.100 / 56. 41.100
libavformat 56. 36.100 / 56. 36.100
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 16.101 / 5. 16.101
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.100 / 1. 2.100
libpostproc 53. 3.100 / 53. 3.100

Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

comment:2 Changed 3 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords Synology infringement violation removed

FFmpeg have a public shaming section of their website to call out the infringers.

No, this was unfortunately removed a long time ago.

Are there downloads available of the binary packages?

comment:3 Changed 3 years ago by cehoyos

Note that assuming your binary is the one that is distributed by Synology this is not a question of them distributing the sources: The binary that you showed console output for cannot be legally distributed, under no circumstances.

comment:4 Changed 3 years ago by cehoyos

A sidenote: Please understand that in case you have free time to invest, it makes not much sense to invest it in software license violations. FFmpeg has hundreds of license violators, Synology is just another one. It is very difficult to succeed in pursuing a violator, and if you lucky sometimes, you cannot be sure what happens with the compensation the project gets.

comment:5 Changed 3 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

See #4341

comment:6 follow-up: Changed 3 years ago by patters

The binary that you showed console output for cannot be legally distributed, under no circumstances

Well that was my thought also - because they enabled the non-free components for libfaac.

It seems that Taiwanese companies like Synology believe they can behave with impunity. But they trade in Europe and the US and have employees here, so they need to be brought into compliance. They exhibit at storage trade shows all over the world, proudly selling products that are - currently at least - based on license infringement.

Last edited 3 years ago by patters (previous) (diff)

comment:7 in reply to: ↑ 6 Changed 3 years ago by cehoyos

Replying to patters:

It seems that Taiwanese companies like Synology believe they can behave with impunity.

Sorry that you misunderstood me before: There are many US-based companies that violate FFmpeg copyrights and there is not much we can do about it, think for example of Digimetrics.

comment:8 follow-up: Changed 3 years ago by patters

So that's it, we just give up? No one from the FFmpeg project even sends Synology an email to alert them of the infringement? They certainly don't care about my individual opinion.

comment:9 in reply to: ↑ 8 Changed 3 years ago by cehoyos

Replying to patters:

So that's it, we just give up? No one from the FFmpeg project even sends Synology an email to alert them of the infringement?

I believe it makes more sense for you (as a user) if the FFmpeg developers (continue to) develop FFmpeg.

They certainly don't care about my individual opinion.

Why would they care about my opinion?
Please understand that we have been through all this. We are thankful for information about copyright infringement but there is not much we can do.

Note: See TracTickets for help on using tickets.