Opened 5 years ago

Closed 5 years ago

#571 closed defect (fixed)

Convert to mp4 from AVI error message

Reported by: bf4648 Owned by:
Priority: minor Component: avcodec
Version: git-master Keywords: verbosity h264
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Here's my ffmpeg version with configuration options:

ffmpeg version N-33761-g73fb23d, Copyright (c) 2000-2011 the FFmpeg developers

built on Oct 18 2011 09:02:35 with gcc 4.5.2
configuration: --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab
libavutil 51. 21. 0 / 51. 21. 0
libavcodec 53. 21. 0 / 53. 21. 0
libavformat 53. 16. 1 / 53. 16. 1
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 43. 7 / 2. 43. 7
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 51. 2. 0 / 51. 2. 0

Here's my input:

@ubuntu:~/Desktop/Q264$ ffmpeg -i sample -vcodec libx264 -vb 750k -acodec libmp3lame -ab 128k -ar 44100 -ac 2 -y output.mp4

Here are my error messages (over and over again):

Error Message:
"frame= 657 fps= 18 q=26.0 size= 2153kB time=00:00:20.46 bitrate= 861.8kbits/missing picture in access unit with size 56
[h264 @ 0x2779be0] no frame!
Error while decoding stream #0.0
[h264 @ 0x2779be0] missing picture in access unit with size 56
[h264 @ 0x2779be0] no frame!"

Attachments (1)

sample (1000.0 KB) - added by bf4648 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by bf4648

comment:1 Changed 5 years ago by cehoyos

What's wrong with output.mp4?

comment:2 Changed 5 years ago by bf4648

Well, it is giving the following error messages over and over again and taking twice as long to convert to mp4:

Error Message:
"frame= 657 fps= 18 q=26.0 size= 2153kB time=00:00:20.46 bitrate= 861.8kbits/missing picture in access unit with size 56
[h264 @ 0x2779be0] no frame!
Error while decoding stream #0.0
[h264 @ 0x2779be0] missing picture in access unit with size 56
[h264 @ 0x2779be0] no frame!"

comment:3 Changed 5 years ago by bf4648

It is also dropping a frame or something because when I play it back the picture is jerky on throughout....

comment:4 Changed 5 years ago by bf4648

Is there any update on this problem yet?

comment:5 Changed 5 years ago by cehoyos

So far, I have not been able to reproduce a frame drop, can you elaborate?

comment:6 Changed 5 years ago by bf4648

Alright, this is the command that I am using on the sample file included in the above attachment:

ubuntu:~/Desktop$ ffmpeg -i sample -vf "scale=0:0,setdar=4:3" -vcodec libx264 -vb 750k -coder 1 -flags +loop -cmp +chroma -partitions +parti8x8+parti4x4+partp8x8+partb8x8 -me_method hex -subq 6 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 1 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -directpred 1 -flags2 +fastpskip -acodec libmp3lame -ab 128k -ar 44100 -ac 2 -y output.mp4

If I use the above command I get the following error messages over and over again:

missing picture in access unit with size 56
[h264 @ 0x1571be0] no frame!
Error while decoding stream #0.0
[h264 @ 0x1571be0] missing picture in access unit with size 56
[h264 @ 0x1571be0] no frame!
Error while decoding stream #0.0

It does output a mp4 file though but on files that are larger sizes (because the sample file is just a sample), it is taking a long time (like 5 minutes for a 5 minute video) and the result file is a lot larger than the other files I've converted. I think it has something to do with the Q264 codec that was used to encode the videos originally. I can encode other videos that were originally encoded using the QIVG codec with the above command and I get no error messages and a 5 minute video is encoded in under a minute. I'd like the videos encoded in the Q264 codec to be re-encoded in under 1 minute just like the videos encoded in the QIVG codec if that is possible.

You can also get more information about the sample using the following command:

ffprobe sample

It will give you all kinds of information and may help explain the problem I'm having.

Last edited 5 years ago by bf4648 (previous) (diff)

comment:7 Changed 5 years ago by cehoyos

So you do not experience frame drop, only warnings on the console, is that correct?

comment:8 follow-up: Changed 5 years ago by bf4648

Well, if you use the command listed above on the sample video, it doesn't drop any frames in the output.mp4 file (not to my knowledge). If I use the above command on other files though, it is taking twice as long and the output is much larger. I would just like to know why it is taking twice as long as opposed to other files encoded with a different codec and why I continue to get error messages like the one listed above over and over again. By the way here is my ffmpeg version:

ffmpeg version N-33795-g891f76b, Copyright (c) 2000-2011 the FFmpeg developers
built on Oct 19 2011 09:10:42 with gcc 4.5.2
configuration: --enable-gpl --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-nonfree --enable-postproc --enable-version3 --enable-x11grab
libavutil 51. 22. 0 / 51. 22. 0
libavcodec 53. 21. 0 / 53. 21. 0
libavformat 53. 16. 1 / 53. 16. 1
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 44. 0 / 2. 44. 0
libswscale 2. 1. 0 / 2. 1. 0
libpostproc 51. 2. 0 / 51. 2. 0

Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Last edited 5 years ago by bf4648 (previous) (diff)

comment:9 in reply to: ↑ 8 Changed 5 years ago by cehoyos

Replying to bf4648:

Well, if you use the command listed above on the sample video, it doesn't drop any frames in the output.mp4 file (not to my knowledge).

If a longer sample is needed to reproduce the frame dropping, please upload to http://www.datafilehost.com/ and post the link here

comment:10 Changed 5 years ago by cehoyos

  • Component changed from avformat to avcodec
  • Keywords verbosity h264 added
  • Priority changed from normal to minor
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed

The warning messages should be silenced, if you still encounter frame drops, please reopen the ticket.

Note: See TracTickets for help on using tickets.