Opened 3 years ago

Closed 7 weeks ago

#5680 closed defect (fixed)

./configure uses `pr`, which isn't provided by busybox

Reported by: somasis Owned by: beastd
Priority: normal Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I submitted a patch to libav for this as well, but I noticed this didn't get merged into ffmpeg. Basically this patch just changes log_file() within ./configure to use printf for the formatting, rather than pr, a POSIX.1 command which is a little obscure (and therefore not provided by busybox), and easily replaceable in its usage.

Attachments (1)

0001-configure-Replace-pr-since-it-is-not-provided-by-bus.patch (1.2 KB) - added by somasis 3 years ago.
[PATCH] configure: Replace pr since it is not provided by busybox

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by somasis

[PATCH] configure: Replace pr since it is not provided by busybox

comment:1 Changed 3 years ago by cehoyos

Please send your patch to the development mailing list, patches are ignored here.
Could you explain how I can reproduce on a random Linux system? (Is it possible?)

comment:2 Changed 3 months ago by cehoyos

  • Version changed from unspecified to git-master

A change to logfile by Yejun Guo, based on the one attached here, was applied as ae6486c6251039d3a6bb5a90e1d818331cf55edc

comment:3 Changed 7 weeks ago by beastd

  • Owner set to beastd
  • Status changed from new to open

comment:4 Changed 7 weeks ago by beastd

  • Resolution set to fixed
  • Status changed from open to closed

Should finally be fixed in commit 99147312ce6ffd3a3b70e10aacc9b64a63b6aefe .

That commit replacing pr for printing listings was not based on the patch attached to this ticket. Please refer to the commit message for details.

Note: See TracTickets for help on using tickets.