Opened 3 years ago

Closed 3 years ago

#5675 closed defect (fixed)

ffmpeg configure script does not detect openssl 1.1 correctly

Reported by: EricV Owned by:
Priority: normal Component: build system
Version: git-master Keywords: libopenssl
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The init function used to detect openssl has changed for openssl 1.1 as explained here : https://wiki.openssl.org/index.php/Library_Initialization

if your replace SSL_library_init by OPENSSL_init_ssl in the check_library pattern all is fine. It correctly builds and links due to a macro that do the conversion.

Attachments (1)

patch_ffmpeg_configure_openssl1.1.diff (1.3 KB) - added by EricV 3 years ago.
Patch to compile with openssl 1.1

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 years ago by cehoyos

  • Keywords libopenssl added
  • Priority changed from important to normal

If you already have a patch that fixes the issue please send it - made with git format-patch - to the FFmpeg development mailing list.

comment:2 Changed 3 years ago by EricV

The patch I have prevents to build with the previous version so it is not complete. Or maybe adding the extra lines for additional checks is sufficient.

Changed 3 years ago by EricV

Patch to compile with openssl 1.1

comment:3 Changed 3 years ago by llogan

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed by Matt Oliver in 798c6ecce50f26a53d48e2577a34fabe46b32eb9.

Note: See TracTickets for help on using tickets.