Opened 8 years ago

Closed 8 years ago

Last modified 16 months ago

#5558 closed defect (wontfix)

concat protocol should run in "-safe 0" mode by default

Reported by: GrayFace Owned by:
Priority: important Component: avformat
Version: git-master Keywords: concat regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
It's very hard for me to imagine a task for which "-safe 1" makes sense. It probably involves list being obtained from outside source instead of being generated. What's for sure is that it's a sophisticated task for which figuring out and specifying additional parameters is not a problem.
For all regular users of "concat" option (me included) the "safe mode" brings only troubles, e.g. https://ffmpeg.org/pipermail/ffmpeg-user/2016-April/031560.html
No one knows why it's there, because the documentation doesn't say anything about rationale: https://www.ffmpeg.org/ffmpeg-formats.html#Options
Obviously, no backward compatibility.

How to reproduce:

% ffmpeg -nostats -f concat -i List.txt -c copy output
(List.txt contains absolute paths)
ffmpeg version N-79947-gcd244fa
built on 20160512

Change History (4)

comment:1 by Carl Eugen Hoyos, 8 years ago

Resolution: wontfix
Status: newclosed

comment:2 by GrayFace, 8 years ago

Replying to cehoyos:

http://seclists.org/oss-sec/2016/q1/85

Wow! Yet, I don't see how this applies to command-line "-f concat" parameter.
First, it talks about "concat:file1|file2" protocol, not "-f concat" demuxer (turns out I was wrong calling it "protocol" in the ticket name).
Second, it talks about it being found in a movie file, obviously an untrusted source, unlike command-line. Shouldn't the list explicitly specified in command line as "-f concat" be trusted (only the list itself, not the movies specified by it)?

Last edited 8 years ago by GrayFace (previous) (diff)

comment:3 by Carl Eugen Hoyos, 8 years ago

Component: undeterminedavformat
Keywords: concat regression added
Priority: normalimportant
Version: unspecifiedgit-master

It is unlikely that the current behaviour will change but feel free to send a patch made with git format-patch to the development mailing list to discuss your intended change.

comment:4 by PierU, 16 months ago

I don't understand how this ticket has not even been considered. On help forums this is a very common mistake of the users to forget -safe 0, and they never understand the error message (besides, the documentation is quite vague about what is a "safe filename"). And I concur with the OP that -safe 0 should be the default for usual tasks, while -safe 1 correspond to uncommon tasks.

Note: See TracTickets for help on using tickets.