#5494 closed defect (fixed)

AV Foundation recording broken

Reported by: LordHDL Owned by:
Priority: important Component: avdevice
Version: git-master Keywords: avfoundation osx codecpar regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary: Recording with AVFoundation does not work anymore.
How to reproduce: Attempt to record with -f avfoundation.

ffmpeg -f avfoundation -i "3:0" -c:v ffvhuff -c:a pcm_s32be ~/Desktop/avf.mkv

Full console output in the attachment.

Attachments (1)

Terminal Saved Output (12.3 KB) - added by LordHDL 20 months ago.

Download all attachments as: .zip

Change History (9)

Changed 20 months ago by LordHDL

comment:1 Changed 20 months ago by cehoyos

  • Keywords osx regression added
  • Priority changed from normal to important

Please use git bisect to find out which change broke avfoundation recording.

comment:2 Changed 20 months ago by LordHDL

This is the console output:

HDLs-MacBook-Pro:ffmpeg HDL$ git bisect start
HDLs-MacBook-Pro:ffmpeg HDL$ git bisect good 5a19506
HDLs-MacBook-Pro:ffmpeg HDL$ git bisect bad 66dd21d
Bisecting: 274 revisions left to test after this (roughly 8 steps)
[27558679a1e0738630254d5398c74eb5d7f45c8d] Merge commit '7480d001312d9ba706333ec970264ed9df3f82cb'

Is there a fast way of testing this other than manually checking out each revision?

comment:3 follow-up: Changed 20 months ago by LordHDL

OK I went through the steps.

HDLs-MacBook-Pro:~ HDL$ cd ffmpeg
HDLs-MacBook-Pro:ffmpeg HDL$ git bisect good 60b7518
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[9200514ad8717c63f82101dc394f4378854325bf] lavf: replace AVStream.codec with AVStream.codecpar

comment:4 in reply to: ↑ 3 Changed 20 months ago by cehoyos

Replying to LordHDL:

HDLs-MacBook-Pro:ffmpeg HDL$ git bisect good 60b7518
Bisecting: 0 revisions left to test after this (roughly 0 steps)

This means you have to do one more test to finish the bisect.

comment:5 Changed 20 months ago by LordHDL

First bad commit seems to be 6f69f7a. I verified the one before it, 60b7518, works properly.

comment:6 Changed 20 months ago by cehoyos

  • Keywords codecpar added
  • Status changed from new to open

comment:8 Changed 20 months ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.