#5484 closed defect (fixed)

build from git fails in libavutil

Reported by: bferrell Owned by:
Priority: normal Component: avutil
Version: git-master Keywords: vaapi
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

./configure \

--enable-gpl \
--enable-libx264 \
--enable-libmp3lame \
--enable-nonfree \
--enable-libfdk-aac \
--prefix=/usr \
--libdir=/usr/lib64 \
--disable-demuxer=matroska \
--disable-muxer=matroska \
--disable-muxer=matroska_audio \
--disable-hwaccels \
--disable-filter=scale_vaapi

libavutil/hwcontext_vaapi.c:66:9: error: ‘VA_FOURCC_ABGR’ undeclared here (not in a function)

VA_FOURCC_ ## va, \

libavutil/hwcontext_vaapi.c:95:5: note: in expansion of macro ‘MAP’

MAP(ABGR, RGB32, ABGR),

common.mak:60: recipe for target 'libavutil/hwcontext_vaapi.o' failed
make: * [libavutil/hwcontext_vaapi.o] Error 1

Attachments (1)

config.log (315.8 KB) - added by bferrell 18 months ago.
config.log

Download all attachments as: .zip

Change History (5)

comment:1 Changed 18 months ago by bferrell

Build environment is opensuse 13.2

comment:2 Changed 18 months ago by jamrial

Technically it shouldn't be needed since you're configuring with --disable-hwaccels, but try configuring with --disable-vaapi. If that works then configure needs to be fixed.

What version of libva are you using for it to be missing that define?

Changed 18 months ago by bferrell

config.log

comment:3 Changed 18 months ago by bferrell

That did work. I'm not certain of the libav so I've attached the config.log

comment:4 Changed 15 months ago by cehoyos

  • Component changed from undetermined to avutil
  • Keywords vaapi added
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.