#5480 closed defect (invalid)

Immense memory use on Mac 32/64 bit while decoding H.264

Reported by: glip Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: h264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

To reproduce I used demuxing_decoding.c from examples with turned off writing to output - just decoding is working (changed file attached).

ffmpeg version N-79632-g3ce1988 Copyright (c) 2000-2016 the FFmpeg developers

built with Apple LLVM version 7.3.0 (clang-703.0.29)
configuration: --prefix=build/macx64 --enable-gpl
libavutil 55. 22.101 / 55. 22.101
libavcodec 57. 38.100 / 57. 38.100
libavformat 57. 34.103 / 57. 34.103
libavdevice 57. 0.101 / 57. 0.101
libavfilter 6. 44.100 / 6. 44.100
libswscale 4. 1.100 / 4. 1.100
libswresample 2. 0.101 / 2. 0.101
libpostproc 54. 0.100 / 54. 0.100

Attachments (3)

valgrind.txt (11.3 KB) - added by glip 18 months ago.
Valgrind
demuxing_decoding.c (13.8 KB) - added by glip 18 months ago.
Modified example
valgrind_full.txt (195.4 KB) - added by glip 18 months ago.
Full valgrind leak report

Download all attachments as: .zip

Change History (5)

Changed 18 months ago by glip

Valgrind

Changed 18 months ago by glip

Modified example

comment:1 Changed 18 months ago by cehoyos

  • Keywords h264 added; h.264 decoding removed
  • Priority changed from important to normal

As-is, this ticket makes little sense: Memory usage for multi-threaded h264 decoding can be (very) high, I don't think this can be fixed (in a useful way), in any case there is already a ticket.
But the valgrind output you provided indicates possible leaks: Did you want to report them? If yes, please test again with --track-origins=yes.

Changed 18 months ago by glip

Full valgrind leak report

comment:2 Changed 18 months ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Afaict, no leaks in your valgrind output are caused by FFmpeg / its libraries.
Feel free to join the discussion in ticket #5224, I don't think there is anything that can be fixed though.

Note: See TracTickets for help on using tickets.