Opened 6 years ago

Closed 5 years ago

Last modified 4 days ago

#5367 closed defect (fixed)

ffmpeg muxing error, no video packets muxed: cur_dts is invalid (this is harmless if it occurs once at the start per stream)

Reported by: leo.z Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: h264 mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi all

I'm using ffmpeg to recode a live mpegts stream, but no video packets muxed, the debug log keep saying: cur_dts is invalid (this is harmless if it occurs once at the start per stream).
the source file recoded using others tools: http://203.118.245.62/hd_spts.ts.
the ffmpeg report file: http://203.118.245.62/ffmpeg-20160323-065632.log

Attachments (4)

ffmpeg-20160627-160404.log (108.2 KB ) - added by Alexander V. Lukyanov 5 years ago.
iptv-raw conversion log
ffmpeg-20160627-160955.log (654.3 KB ) - added by Alexander V. Lukyanov 5 years ago.
iptv-raw conversion log from ffmpeg git d693392886b8454c818e384c816b9ede53c570d8
hd_spts_cut.ts (2.4 MB ) - added by Carl Eugen Hoyos 5 years ago.
iptv-raw_cut (2.4 MB ) - added by Carl Eugen Hoyos 5 years ago.

Change History (10)

comment:1 by Carl Eugen Hoyos, 6 years ago

Keywords: cur_dts is invalid removed

Please provide the command line that allows to reproduce the issue together with the complete, uncut console output here on the bug tracker to make this a valid ticket: External resources may disappear.

comment:2 by leo.z, 6 years ago

Following are the uncut console output:
iptv@ubuntu:~$ ffmpeg -y -i hd_spts.ts -c copy -f mpegts 1.ts
ffmpeg version 3.0-static http://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2016 the FFmpeg developers

built with gcc 5.3.1 (Debian 5.3.1-8) 20160205
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --enable-frei0r --enable-libfribidi --disable-indev=sndio --disable-outdev=sndio --enable-librtmp --enable-libmfx --cc=gcc
libavutil 55. 17.103 / 55. 17.103
libavcodec 57. 24.102 / 57. 24.102
libavformat 57. 25.100 / 57. 25.100
libavdevice 57. 0.101 / 57. 0.101
libavfilter 6. 31.100 / 6. 31.100
libswscale 4. 0.100 / 4. 0.100
libswresample 2. 0.101 / 2. 0.101
libpostproc 54. 0.100 / 54. 0.100

[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 1 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 2 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced
[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
[h264 @ 0xb6bdf80] non-existing PPS 0 referenced

Last message repeated 1 times

[h264 @ 0xb6bdf80] decode_slice_header error
[h264 @ 0xb6bdf80] no frame!
Input #0, mpegts, from 'hd_spts.ts':

Duration: 00:01:43.30, start: 16966.364000, bitrate: 8120 kb/s
Program 352

Metadata:

service_name : FIGHT SPORTS HD
service_provider:

Stream #0:0[0xc0]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 25 tbr, 90k tbn, 50 tbc
Stream #0:1[0x124]: Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, s16p, 192 kb/s

Output #0, mpegts, to '1.ts':

Metadata:

encoder : Lavf57.25.100
Stream #0:0: Video: h264 ([27][0][0][0] / 0x001B), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], q=2-31, 25 fps, 25 tbr, 90k tbn, 90k tbc
Stream #0:1: Audio: mp2 ([3][0][0][0] / 0x0003), 48000 Hz, stereo, 192 kb/s

Stream mapping:

Stream #0:0 -> #0:0 (copy)
Stream #0:1 -> #0:1 (copy)

Press [q] to stop, ? for help
frame= 0 fps=0.0 q=-1.0 Lsize= 2657kB time=00:01:42.91 bitrate= 211.5kbits/s speed= 195x
video:0kB audio:2411kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 10.197172%

no video muxed.
i have looked into the code, it seems there are something wrong with the AVPackets which av_read_frame returned, the dts/pts value was set to AV_NOPTS_VALUE of the every other returned AVPackets, kind of divided one frame to two AVPacket.

would you please take some time looking into it, thanks.

Last edited 6 years ago by leo.z (previous) (diff)

comment:3 by Carl Eugen Hoyos, 6 years ago

Resolution: needs_more_info
Status: newclosed

Feel free to reopen this ticket if you can provide the command line that allows to reproduce this issue together with the complete, uncut console output.

comment:4 by Alexander V. Lukyanov, 5 years ago

Resolution: needs_more_info
Status: closedreopened

Please look at this iptv sample:
https://drive.google.com/file/d/0B0laIcbq4vKRV1g0c1B4NGREZ1E/view?usp=sharing

ffplay can show the video, but ffmpeg cannot copy it using this command line:

ffmpeg -report -y -ss 5 -i iptv-raw -t 30 -c copy /tmp/a.avi

The diagnostics looks very similar to the report of the topic starter.

by Alexander V. Lukyanov, 5 years ago

Attachment: ffmpeg-20160627-160404.log added

iptv-raw conversion log

by Alexander V. Lukyanov, 5 years ago

Attachment: ffmpeg-20160627-160955.log added

iptv-raw conversion log from ffmpeg git d693392886b8454c818e384c816b9ede53c570d8

comment:5 by Carl Eugen Hoyos, 5 years ago

Keywords: h264 mpegts added
Resolution: duplicate
Status: reopenedclosed

I believe this is a duplicate of ticket #5088.

by Carl Eugen Hoyos, 5 years ago

Attachment: hd_spts_cut.ts added

by Carl Eugen Hoyos, 5 years ago

Attachment: iptv-raw_cut added

comment:6 by aalku, 4 days ago

Resolution: duplicatefixed

Errors are different than in #5088 so i'll mark it as fixed rather than duplicated.
I think "cur_dts is invalid" is an important difference.
I started with a prepared "ffmpeg version n4.2.2" package stripped from almost all modules and got that "cur_dts is invalid" error and getting no video trying to read some input file until I recompiled enabling this two parsers when calling configure:

  --enable-parser=h264
  --enable-parser=acc

In other cases this might be the problem or else it may have been fixed in this years.

Maybe this can help someone anyway.

Note: See TracTickets for help on using tickets.