Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#5214 closed defect (invalid)

Corrupted WebM VP9 from .MOV file

Reported by: jlgrall Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: libvpx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: encoding this .mov file produces a corrupted .webm VP9 file

How to reproduce:

% "C:\Documents and Settings\jlgrall\Local Settings\Application Data\dmMediaConverter\Config\ffmpeg.exe" -fflags +genpts -y -i "C:\videos\flaque2.mov" -map 0:0 -c:v:0 libvpx-vp9 -crf:v:0 10 -metadata:s:v:0 "creation_time=2004-08-06 17\:17\:54" -metadata:s:v:0 "language=eng" -metadata:s:v:0 "handler_name=Gestionnaire d�alias Apple" -metadata:s:v:0 "encoder=Vidéo" -threads:v:0 2 -shortest "C:\videos\flaque2-20160129-git-5893e87.webm"

ffmpeg 20160129-git-5893e87 downloaded precompiled.
Windows XP SP3

Source .mov file: http://atelier-st-andre.net/tests/error-ff43-webm-vp9/flaque2.mov
Output .webm file: http://atelier-st-andre.net/tests/error-ff43-webm-vp9/flaque2-20160129-git-5893e87.webm

The corrupted .webm file:

Change History (4)

comment:1 in reply to: ↑ description ; follow-up: Changed 2 years ago by cehoyos

Replying to jlgrall:

  • is played by Chromium 48 without problem

What makes you think that the output file is corrupt?
It plays fine here with FFplay.
Reading the bug reports you linked, it seems that both vlc and Firefox fixed playback.

comment:2 in reply to: ↑ 1 Changed 2 years ago by jlgrall

Replying to cehoyos:

What makes you think that the output file is corrupt?

In the Firfox bug report, ​Nicolas Silva says in comment 6:

The reason this video is failing is that its cb and cr planes are slightly bugger than its y planes, in the texture allocation code there's a sanity check that the y size is superior or equal to the y size and I indeed added the check in that range.

Also, ​Jean-Yves Avenard says in comment 13:

Personally here, I wouldn't apply those changes: the video is invalid, that we used to play it was a bug :)
It's the media that needs fixing.

I am going to point them to this bug report, I hope they can give us more informations.

Note: in the Firefox bug report, the .webm file was encoded with ffmpeg v2.8.1. The latest ffmpeg 20160129-git-5893e87 output .webm still crashes Firefox and VLC, but maybe it is a bit different cause, because a binary diff shows that the output .webm files have a lot of differences between ffmpeg 2.8.1 and ffmpeg 20160129-git-5893e87.

Last edited 2 years ago by jlgrall (previous) (diff)

comment:3 Changed 2 years ago by cehoyos

  • Keywords libvpx added
  • Resolution set to invalid
  • Status changed from new to closed

Note that the differences are most likely due to different versions if libvpx used for compilation: FFmpeg is unable to do vp9 encoding.
Since the decoding application of current libvpx decoded the file you provided without issues, I'll close this ticket as invalid. Feel free to reopen if you can explain what is invalid about the file.

Last edited 2 years ago by cehoyos (previous) (diff)

comment:4 Changed 2 years ago by jlgrall

From Firfox bug report comment 28:

The sizes of the YCbCr planes are nonsensical.

So that seems to be the problem with the .webm file. Here I reported it to the libvpx library: https://bugs.chromium.org/p/webm/issues/detail?id=1142

Thanks for your help.

Note: See TracTickets for help on using tickets.