Opened 2 years ago

Closed 3 months ago

#5094 closed defect (invalid)

ffserver HTTP chunked encoding

Reported by: kevg Owned by:
Priority: normal Component: ffserver
Version: git-master Keywords: http
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


I'm trying to stream video to ffserver via HTTP. But it doesn't work because ffserver is unable to parse chunked encoding correctly. It reads chunk length, then reads chunk itself but not reads chunk footer "\r\n". In the next iteration it reads the length of the next chunk size, but this is a footer of the first chunk. Length parsed is 0. ffserver decides stream has ended and closes it.

  1. Reading chunk length
  1. Reading chunk data

  1. Missed reading of "\r\n"
chunk = chunk-size [ chunk-extension ] CRLF

chunk-data CRLF

Change History (1)

comment:1 Changed 3 months ago by atomnuker

  • Resolution set to invalid
  • Status changed from new to closed

ffserver was removed from git master, closing bug as invalid

Note: See TracTickets for help on using tickets.