Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#5029 closed defect (fixed)

AVCI50 mxf file not supported

Reported by: cehoyos Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mxf h264 videolan
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description (last modified by cehoyos)

(vlc ticket 15762)
A user uploaded a AVCI50 mxf file that does not work with current FFmpeg because an incorrect SPS/PPS is selected (coded width is 1440, but only the value 1920 can be found in the file) and a matching mov file and a (working) AVCI100 mxf file.

$ ffmpeg -i Train\ \(AVC-Intra\,\ 50\ Mbps\,\ No\ Frames\ SPS-PPS\ Header\).mxf
ffmpeg version N-76792-g64db363 Copyright (c) 2000-2015 the FFmpeg developers
  built with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      55.  8.100 / 55.  8.100
  libavcodec     57. 16.100 / 57. 16.100
  libavformat    57. 19.100 / 57. 19.100
  libavdevice    57.  0.100 / 57.  0.100
  libavfilter     6. 15.100 /  6. 15.100
  libswscale      4.  0.100 /  4.  0.100
  libswresample   2.  0.101 /  2.  0.101
  libpostproc    54.  0.100 / 54.  0.100
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] negative number of zero coeffs at 66 4
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra mode at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra mode at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] out of range intra chroma pred mode at 24 21
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] top block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] corrupted macroblock 36 30 (total_coeff=-1)
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] top block unavailable for requested intra mode at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] top block unavailable for requested intra mode at 48 40
[h264 @ 0x393af00] error while decoding MB 48 40
[h264 @ 0x393af00] top block unavailable for requested intra mode at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 66 5
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra mode at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 24 21
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] left block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] left block unavailable for requested intra mode at 36 31
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] cbp too large (53) at 48 40
[h264 @ 0x393af00] error while decoding MB 48 40
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] mb_type 28 in I slice too large at 66 5
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra mode at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] negative number of zero coeffs at 24 20
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] top block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] top block unavailable for requested intra mode at 36 31
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] left block unavailable for requested intra4x4 mode -1 at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 49 40
[h264 @ 0x393af00] error while decoding MB 49 40
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] negative number of zero coeffs at 66 4
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 24 21
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] top block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] top block unavailable for requested intra mode at 36 31
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] top block unavailable for requested intra mode at 104 34
[h264 @ 0x393af00] error while decoding MB 104 34
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 49 40
[h264 @ 0x393af00] error while decoding MB 49 40
[h264 @ 0x393af00] left block unavailable for requested intra mode at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] out of range intra chroma pred mode at 66 4
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra mode at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] mb_type 29 in I slice too large at 24 21
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] left block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 36 31
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] left block unavailable for requested intra mode at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] cbp too large (49) at 48 40
[h264 @ 0x393af00] error while decoding MB 48 40
[h264 @ 0x393af00] top block unavailable for requested intra mode at 114 44
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] left block unavailable for requested intra mode at 0 1
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] out of range intra chroma pred mode at 67 4
[h264 @ 0x393af00] error while decoding MB 67 4
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] left block unavailable for requested intra mode at 24 21
[h264 @ 0x393af00] error while decoding MB 24 20
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 36 31
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 48 41
[h264 @ 0x393af00] error while decoding MB 48 40
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
[h264 @ 0x393af00] out of range intra chroma pred mode at 0 0
[h264 @ 0x393af00] error while decoding MB 0 0
[h264 @ 0x393af00] out of range intra chroma pred mode at 66 4
[h264 @ 0x393af00] error while decoding MB 66 4
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 12 10
[h264 @ 0x393af00] error while decoding MB 12 10
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 78 14
[h264 @ 0x393af00] error while decoding MB 78 14
[h264 @ 0x393af00] top block unavailable for requested intra4x4 mode -1 at 25 20
[h264 @ 0x393af00] error while decoding MB 25 20
[h264 @ 0x393af00] left block unavailable for requested intra mode at 90 25
[h264 @ 0x393af00] error while decoding MB 90 24
[h264 @ 0x393af00] negative number of zero coeffs at 36 30
[h264 @ 0x393af00] error while decoding MB 36 30
[h264 @ 0x393af00] left block unavailable for requested intra mode at 102 35
[h264 @ 0x393af00] error while decoding MB 102 34
[h264 @ 0x393af00] cbp too large (53) at 48 40
[h264 @ 0x393af00] error while decoding MB 48 40
[h264 @ 0x393af00] out of range intra chroma pred mode at 114 45
[h264 @ 0x393af00] error while decoding MB 114 44
[h264 @ 0x393af00] concealing 8160 DC, 8160 AC, 8160 MV errors in I frame
Guessed Channel Layout for  Input Stream #0.1 : mono
Guessed Channel Layout for  Input Stream #0.2 : mono
Guessed Channel Layout for  Input Stream #0.3 : mono
Guessed Channel Layout for  Input Stream #0.4 : mono
Input #0, mxf, from 'Train (AVC-Intra, 50 Mbps, No Frames SPS-PPS Header).mxf':
  Metadata:
    uid             : 0bce48bd-703c-4c65-876a-307b42807ce0
    generation_uid  : b3312033-880d-4f68-abbd-532d008b14e7
    modification_date: 2015-10-27 11:37:40
    company_name    : Building4Media
    product_name    : FORK
    product_version : 4.5
    product_uid     : 00000000-0000-0000-0000-000000000000
    application_platform: libMXF (Intel Darwin 32-bit)
    material_package_umid: 0x060A2B340101010501010D4313000000BCE416AD924205D30080458238BCE02C
    material_package_name: None
    timecode        : 02:00:02;14
  Duration: 00:00:00.83, start: 0.000000, bitrate: 59007 kb/s
    Stream #0:0: Video: h264 (High 4:2:2 Intra), yuv422p10le(pc, bt709), 1920x1080 [SAR 1:1 DAR 16:9], 29.97 fps, 29.97 tbr, 29.97 tbn, 50 tbc
    Metadata:
      file_package_umid: 0x060A2B34010101050101064313000000BCE416AD924205D40080458238BCE02C
    Stream #0:1: Audio: pcm_s16le, 48000 Hz, 1 channels, s16, 768 kb/s
    Metadata:
      file_package_umid: 0x060A2B34010101050101064313000000BCE416AD924205D40080458238BCE02C
    Stream #0:2: Audio: pcm_s16le, 48000 Hz, 1 channels, s16, 768 kb/s
    Metadata:
      file_package_umid: 0x060A2B34010101050101064313000000BCE416AD924205D40080458238BCE02C
    Stream #0:3: Audio: pcm_s16le, 48000 Hz, 1 channels, s16, 768 kb/s
    Metadata:
      file_package_umid: 0x060A2B34010101050101064313000000BCE416AD924205D40080458238BCE02C
    Stream #0:4: Audio: pcm_s16le, 48000 Hz, 1 channels, s16, 768 kb/s
    Metadata:
      file_package_umid: 0x060A2B34010101050101064313000000BCE416AD924205D40080458238BCE02C
At least one output file must be specified

Change History (3)

comment:1 Changed 3 years ago by cehoyos

I uploaded the failing file, the matching mov file (that selects the correct SPS/PPS because the coded_width is set to 1440) and the AVCI100 mxf file that selects the right SPS/PPS because of the width being 1920 to http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket5029/

comment:2 Changed 3 years ago by cehoyos

  • Description modified (diff)

comment:3 Changed 3 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed
Last edited 3 years ago by cehoyos (previous) (diff)
Note: See TracTickets for help on using tickets.