Opened 5 years ago

Closed 5 years ago

#501 closed defect (needs_more_info)

Extract thumbnails with -ss from WMV big

Reported by: plaguebreath Owned by: michael
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have 3 WMV files bigger then 3 hours each, I have to extract 6 frames from each at fix time, so I have to make a loop with that command:

ffmpeg -ss 2788 -i "1.wmv" -an -sameq -v 9 -loglevel 99 -vframes 1 -y "1_.jpg"

After few minutes of DROP LINE like

20:40:19 - frame= 0 fps= 0 q=0.0 size= 0kB time=00:00:00.00 bitrate= 0.0kbits/s dup=0 drop=2019
20:40:19 - frame= 0 fps= 0 q=0.0 size= 0kB time=00:00:00.00 bitrate= 0.0kbits/s dup=0 drop=2141 

ffmpeg crash with APPCRASH C0000005 error.

I tried a very old version I still had on hd FFmpeg version SVN-r26400
that one work and differ from the newer from the fact that it output something like that:

20:59:54 - frame=    0 fps=  0 q=0.0 size=       0kB time=10000000000.00 bitrate=   0.0kbits/s dup=0 drop=26043    
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1193 DC, 1193 AC, 1193 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1193 DC, 1193 AC, 1193 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:54 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:54 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1193 DC, 1193 AC, 1193 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1193 DC, 1193 AC, 1193 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1193 DC, 1193 AC, 1193 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 793 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1194 DC, 1194 AC, 1194 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 498 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1195 DC, 1195 AC, 1195 MV errors
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 746 > 496
20:59:55 - [wmv3 @ 03030160] concealing 1198 DC, 1198 AC, 1198 MV errors
20:59:55 - frame=    0 fps=  0 q=0.0 size=       0kB time=10000000000.00 bitrate=   0.0kbits/s dup=0 drop=26079    
20:59:55 - [wmv3 @ 03030160] Bits overconsumption: 884 > 496

but not crash even if it is bitter slower then others. What's the issue about the drop and crash ? Attach the log untill crash.

Attachments (1)

log.txt (2.4 MB) - added by plaguebreath 5 years ago.
partial output before crash

Change History (5)

Changed 5 years ago by plaguebreath

partial output before crash

comment:1 Changed 5 years ago by plaguebreath

I'm actually working on windows 7 64bit but I'm using 32bit ffmpeg. Tried all version untill 19/09/2011 still crash.

comment:2 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords APPCRASH c0000005 removed

All necessary information missing, please read http://ffmpeg.org/bugreports.html
(gdb works fine on Windows.)

comment:3 Changed 5 years ago by plaguebreath

I'm not so great user of MinGW but actually refering to the link you post me I did all but GDB stuff, but that's because I don't see in any place any ffmpeg_g.exe to launch with gdb. Plus I did further test and with the 64bit version with same switch it never crash at all so it is definitively a problem of 32bit version.

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen if you can provide a backtrace or a sample.

Note: See TracTickets for help on using tickets.