Opened 8 years ago

Last modified 7 months ago

#4976 open enhancement

BK2 format support

Reported by: bugme Owned by: PCUser
Priority: wish Component: avcodec
Version: git-master Keywords: bk2
Cc: mirh Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: FFMpeg can't handle new RAD video tools format - BK2.

How to reproduce: example http://www.datafilehost.com/d/022aac05

Issue 2070 did't match with this request I suppose.

Change History (20)

comment:1 by James, 8 years ago

Priority: normalwish
Summary: [request] BK2 format supportBK2 format support
Version: unspecifiedgit-master

comment:2 by Elon Musk, 7 years ago

Resolution: needs_more_info
Status: newclosed

Samples are gone.

comment:3 by Carl Eugen Hoyos, 7 years ago

Cc: James added

James, could you point us to the sample?

comment:4 by James, 7 years ago

Cc: James removed

https://www.sendspace.com/file/m70wus

Good thing i didn't delete it back then, i guess.

comment:5 by Carl Eugen Hoyos, 7 years ago

Resolution: needs_more_info
Status: closedreopened

comment:6 by Elon Musk, 5 years ago

Component: undeterminedavcodec
Status: reopenedopen

comment:7 by Carl Eugen Hoyos, 5 years ago

Keywords: bk2 added

comment:8 by sodanakin, 3 years ago

bump

comment:9 by PCUser, 2 years ago

Component: avcodecffplay
Owner: set to PCUser
Priority: wishcritical
Version: git-master4.4.1

comment:10 by Marton Balint, 2 years ago

Component: ffplayavcodec
Priority: criticalwish
Version: 4.4.1git-master

This is not critical, but an enhancement request, therefore wish. It also affects git master. Also the code component for decoding video is avcodec, ffplay is the player only (which relies on the core component).

in reply to:  10 comment:11 by PCUser, 2 years ago

Replying to Marton Balint:

This is not critical, but an enhancement request, therefore wish. It also affects git master. Also the code component for decoding video is avcodec, ffplay is the player only (which relies on the core component).

Why don't you add Bink 2 to FFmpeg after 6 years!?

Last edited 2 years ago by PCUser (previous) (diff)

comment:13 by Elon Musk, 22 months ago

Your biased and sinister criticism is certainly not going to help.

comment:14 by biast12, 17 months ago

Hey, so it looks like some of Apex Legends .bik files are Bink2 so i was wondering if that maybe could be added or if there's at least a plan to do it, would be really useful if we actually could decode them

if you guys needs some of the videos to test then here: https://videndjurs-my.sharepoint.com/:f:/g/personal/tobi6281_videndjurs_net/EvUvnWGg8MRAggjH3MSiC-gBLPQ3kg9s-z7CRcW0qMzljQ?e=gQTl3z

comment:15 by Nightingale, 7 months ago

Really wanting bk2 support. Any way I can help? Kinda sad it's been 8 years...

comment:16 by Cigaes, 7 months ago

Sure there is a way you can help: start your favorite code editor, implement it and send the patch to the mailing-list. Do not forget to read the guidelines for formatting code and for writing on the mailing-list.

in reply to:  16 comment:17 by Nightingale, 7 months ago

Replying to Cigaes:

Sure there is a way you can help: start your favorite code editor, implement it and send the patch to the mailing-list. Do not forget to read the guidelines for formatting code and for writing on the mailing-list.

Alright, so the community is a bit toxic... I understand.

I've uploaded a .bk2 file that has multiple audio tracks here. It's from the Halo 2 Remaster:
https://drive.google.com/file/d/1_-Sw1XVqoCAAWvhVvpt3G4ZVRDzBRVF8/view?usp=sharing
I'll leave this link up permanently if anyone needs a file to test with. Thank you!

comment:18 by Elon Musk, 7 months ago

There are only toxic users that want free lunch.

comment:19 by mirh, 7 months ago

There's nothing negative into underlining that manpower is the only limitation (conversely, I apologize for mistaking the same problem, as a lack of "sociability")

https://git.nihav.org/?p=nihav.git;a=blob;f=nihav-rad/src/codecs/bink2.rs;hb=HEAD
https://github.com/richardpl/FFmpeg/commit/7ab92509994dac1dc181cc5f99c45e3e80cd13bf
Somebody just has to take the (not negligible) bother of making any of this code fit into master.

comment:20 by Elon Musk, 7 months ago

Both links are not complete and bug-free decoders.

Note: See TracTickets for help on using tickets.