Opened 3 years ago

Closed 3 years ago

#4972 closed defect (needs_more_info)

Source and Destination have different frame counts

Reported by: gzrw Owned by:
Priority: normal Component: ffmpeg
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:I encode a clip cut from a film, the frames count of the source is 14408, that of encoded result is 14411. I have almost gone crazy for days, the -vsync options does not resolve my problem at all.
How to reproduce:

% rem ffmpeg -y -i 0.264 -c:v libx264 -b:v 700k -s 720x480 -preset fast -f mpegts 0_1.264

ffmpeg version N-71455-gfbdaebb Copyright
built with gcc 4.9.2 (GCC)

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Attachments (1)

00.264 (1.7 MB) - added by gzrw 3 years ago.
File with decoding error

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by gzrw

I cut a 10-minute clip directly from a .mkv file then convert it into .264 file, I took a close look at the I frame next to this clip ,It's exactly a IDR. I did not understand why ffmpeg generates 3 more frames to my result compared to the source. I think that must be an important issue in cutting file.

Your early reply is appreciated. The source file is over 1G, I can submit it while necessary.

comment:2 Changed 3 years ago by gzrw

  • Reproduced by developer set

comment:3 follow-up: Changed 3 years ago by cehoyos

  • Keywords different frame counts removed
  • Priority changed from important to normal
  • Reproduced by developer unset

Please provide the command line that allows to reproduce the bug together with the complete, uncut console output to make this a valid ticket.

comment:4 in reply to: ↑ 3 Changed 3 years ago by gzrw

Actually the problem is in decoding process, the command line is as follows:
ffmpeg -y -i 0.ts -f yuv4mpegpipe nul

There is no open GOP in the source file, I don't know why there are frames more than the source, how can I avoid more frames while decoding? Is there any options for me to add in ffmpeg command line?

The source file is too large to upload. Is anyone had the same experience and solved the problem?

Replying to cehoyos:

Please provide the command line that allows to reproduce the bug together with the complete, uncut console output to make this a valid ticket.

comment:5 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can provide the command line that allows to reproduce the issue together with the complete, uncut console output.

comment:6 Changed 3 years ago by gzrw

  • Resolution needs_more_info deleted
  • Status changed from closed to reopened

How to reproduce:

ffmpeg -y -i 00.264 -f yuv4mpegpipe nul

ffmpeg version N-71455-gfbdaebb Copyright
built with gcc 4.9.2 (GCC)

Changed 3 years ago by gzrw

File with decoding error

comment:7 Changed 3 years ago by gzrw

Running the command can decode the attached file. The file has 18 frames, but generates 19 frames after being decoded. Please take a look at the error. Your early reply is appreciated.

comment:8 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from reopened to closed

Please reopen this ticket if you can provide the command line that allows to reproduce the issue together with the complete, uncut console output.

Note: See TracTickets for help on using tickets.