Opened 4 years ago

Closed 4 years ago

#4911 closed enhancement (invalid)

support for Lab color space

Reported by: ponpon Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Dear ffmpeg team,

though i know ffmpeg suppor XYZ color space, i request support for Lab color space.
this is because not only Lab color space includes RGB, YCbCr, and CMYK but also it is designed to approximate the human visual than XYZ. It has an emphasis on perceptual uniformity, L component value is very close to the perception of the human brightness.
this means its effect is produced when filtering a video to make a beautiful RGB or YCbCr video.
for example, when modifying or improve a picture, the use of Lab color space is in general.
i believe this enhances ffmpeg.

Lab color space

https://en.wikipedia.org/wiki/Lab_color_space

Change History (6)

comment:1 Changed 4 years ago by cehoyos

Sorry, this is way too vague:
Do you have an input file that cannot be processed? Or is there a type of output file that is unsupported?

comment:2 Changed 4 years ago by ponpon

sorry for my vague explanation.

as you know, we can see pixel formats ffmpeg supports with ffmpeg -pix_fmts.
from this, i have known xyz12le and xyz12be are supported. but i couldn't have found Lab color space.
the beneficialness of Lab color space can been see at the below links.
https://helpx.adobe.com/photoshop/using/color-modes.html#lab_color_mode
http://photo.net/learn/digital-photography-workflow/advanced-photoshop-tutorials/using-lab-color-adjustments/
http://photo.net/learn/digital-photography-workflow/advanced-photoshop-tutorials/sharpening-in-lab-color/
http://www.photoshopstar.com/basics/photos-lab-color-mode/

i know recent the enhancement of color filters by ffmpeg. i believe this color space is useful for those filters or video quality.

comment:3 Changed 4 years ago by cehoyos

Could you elaborate a little? Which filter would profit? Note that no (non-trivial) filter supports xyz, the pix_fmt is needed to be able to decode some j2k samples.
And what should be done with the output of these "enhanced" filters? Isn't FFmpeg used to produce videos that can be played with media players?

comment:4 Changed 4 years ago by cehoyos

You wrote above make a beautiful RGB or YCbCr video. Could you elaborate? Are you talking about gif files?

comment:5 follow-up: Changed 4 years ago by ponpon

thank for your reply and pointing out not enough explanation.

You wrote above make a beautiful RGB or YCbCr video.

yes. thank you for your understanding regardless of vague explanation! ! !
Lab color space produces its effect in filtering rather than pix_fmt of a final output.
as you know, ffmpeg can change pix_fmt in video filter.
difference, a case of unsharp
http://aska-sg.net/pstips/_images/filter/sharp-01/010.jpg

Could you elaborate?

i done with a trial version of photoshop before. photoshop can import and modify a movie, though it is little is known concerning.
now i can't use photoshop because the trial version is expired and it is too expensive.

Are you talking about gif files?

not only gif but also mpeg2, mp4, mkv, etc. because Lab color space produces its effect in filtering.

comment:6 in reply to: ↑ 5 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Replying to ponpon:

Are you talking about gif files?

not only gif but also mpeg2, mp4, mkv, etc. because Lab color space produces its effect in filtering.

None of the formats you mention support RGB or YCbCR colourspace so I don't think this is a valid ticket.

Note: See TracTickets for help on using tickets.