Opened 4 years ago

Closed 4 years ago

#4769 closed defect (fixed)

Concatenate: Audio and Video out of sync after a couple of rounds

Reported by: Timster Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: concat regression
Cc: ecronik@gmail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello!

Summary of the bug:

There is an issue with concatenating video files. After several rounds of concatenation, the audio and video desync. The issue also occurs when just concatenating one video file with itself several times so it can't be due to video/audio settings being incompatible with each other. Different containers/settings as well don't change anything.

This is the command I am using:

ffmpeg -f concat -i <(for i in seq 5; do printf "file %s\n" /path/to/*.mkv; done) -c:v h264 -preset slow -b:v 1500k -minrate 1500k -maxrate 1500k -bufsize 1500k -g 80 -c:a copy out1.mkv

It is a regression - I've have tested it with the static build ffmpeg.static.64bit.2014-07-16 - it is working there. With my ppa build or the git build it doesn't. The output is attached - produced with the ppa build.

Best,
Tim

Attachments (2)

ffmpeg.txt (31.5 KB) - added by Timster 4 years ago.
ffmpeg output
ffmpeg_mpeg4.txt (1.5 MB) - added by Timster 4 years ago.
mpeg4 output

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by Timster

ffmpeg output

comment:1 Changed 4 years ago by Timster

  • Priority changed from normal to important

comment:2 Changed 4 years ago by Timster

P.S.: It doesn't work without a wildcard as well.

ffmpeg -f concat -i <(for i in seq 5; do printf "file %s\n" /path/to/out.mkv; done) -c:v h264 -preset slow -b:v 1500k -minrate 1500k -maxrate 1500k -bufsize 1500k -g 80 -c:a copy out1.mkv

comment:3 Changed 4 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Keywords concat added; ffmpeg concatenate desync audio video removed
  • Priority changed from important to normal

Is the issue only reproducible with x264 or also with an internal encoder like mpeg4?
Please provide your input sample.

Changed 4 years ago by Timster

mpeg4 output

comment:4 Changed 4 years ago by Timster

The issue is still there when using mpeg4. The sample can be found on your ftp in /incoming/

comment:5 Changed 4 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important

I concatenated the file you uploaded 12 times with the command line you provided and the output file plays in sync here with FFplay. What kind of desync do you see with your output file?

Perhaps you can cut the input file with mkvmergem that would make testing easier.

And since you report a regression that I cannot reproduce: Please run git bisect to find the change introducing the issue.

comment:6 Changed 4 years ago by cehoyos

Or is this ticket a duplicate of #4765 and was fixed yesterday?

comment:7 Changed 4 years ago by Timster

  • Resolution set to fixed
  • Status changed from new to closed

I have tested it with a static git build from 08/11/2015 and it seems to be fixed now. Thanks for your efforts!

Note: See TracTickets for help on using tickets.