Opened 4 years ago

Closed 4 years ago

#4745 closed defect (fixed)

FFmpeg 2.7.2 fails to build on MIPS

Reported by: brad Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: mips
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes

Description

Switching from FFmpeg 2.7 to 2.7.2 there has been a regression with building on MIPS. The build uses all of the various command line parameters to disable the various MIPS features for newer chips..

--disable-loongson3 --disable-mips32r5 --disable-mips64r6 --disable-mipsdspr1 --disable-mipsdspr2 --disable-msa

The compiler is GCC 4.2.1.

The build fails like so..

In file included from libavcodec/mips/hevcdsp_init_mips.c:21:
./libavcodec/mips/hevcdsp_mips.h:35:1: error: pasting
"ff_hevc_put_hevc_pel_pixels" and "##" does not give a valid preprocessing
token

Attachments (2)

hevcdsp_mips.h.gcc42.diff (708 bytes) - added by jamrial 4 years ago.
hevcdsp_mips.h.gcc42.diff-2 (2.8 KB) - added by brad 4 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by cehoyos

  • Priority changed from important to normal

Please update your compiler and please test current FFmpeg git head.
To make this a valid ticket, please provide your configure line, run make V=1 several times and provide the complete, uncut console output of the last run.

comment:2 Changed 4 years ago by brad

I'll check git master, but the compiler isn't changing. This is what it has to build with and what we've used to build FFmpeg for quite a few releases now.

Changed 4 years ago by jamrial

comment:3 Changed 4 years ago by jamrial

Are you sure it worked with ffmpeg 2.7, or you meant to say 2.6?
The line that gives that error has been in the tree since the 2.7 release and hasn't changed since. The entire mips folder apparently hasn't changed from 2.7 to 2.7.2, even.

Can you try the attached patch and see if it fixes the error for you?

comment:4 Changed 4 years ago by brad

Ok, taking your patch and expanding upon it to cover the other macros that were having issues compiling it is now compiled Ok and working.

Changed 4 years ago by brad

comment:5 Changed 4 years ago by jamrial

  • Analyzed by developer set
  • Keywords mips added
  • Status changed from new to open
  • Version changed from 2.7 to git-master

Patch to fix this on the ml.

comment:6 Changed 4 years ago by brad

Great, thank you.

comment:7 Changed 4 years ago by jamrial

  • Resolution set to fixed
  • Status changed from open to closed

Fixed in a0092cea462ff4f203aaff09c42c6731c6516b44 and backported for ffmpeg 2.7.3

Note: See TracTickets for help on using tickets.