Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4743 closed defect (fixed)

Opus ogg file is silent when looping playback.

Reported by: Dale Curtis Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: opus, ogg
Cc: Michael Niedermayer Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

ffmpeg -i sfx_f32le.wav -acodec opus sfx-opus.ogg
ffmpeg -i sfx_f32le.wav -acodec libopus sfx-libopus.ogg

Now play either file with ffplay and wait for playback to finish then seek to zero, observe silence. That's as far as I could get with debugging with the CLI tools.

Using Chrome's decoder implementation, I can see that seeking to -7000 instead of the start time of -6500 (as indicated by first packet pts) will return all the correct packets. Otherwise the packets get consecutive pts values starting from 1, with all of their content marked for end trimming.

[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 0
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 960
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 1920
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 2880
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 3840
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 4800
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 5760
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 6720
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 7680
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 8640
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 9600
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 10560
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 11520
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 12480
[1:9:0728/153127:ERROR:ffmpeg_demuxer.cc(1258)] pts: 13440
[1:9:0728/153127:ERROR:audio_discard_helper.cc(222)] End discard of 244 out of 960
[1:9:0728/153128:ERROR:ffmpeg_demuxer.cc(681)] Seeking to: -6500, -312 in stream 0
[1:9:0728/153128:ERROR:ffmpeg_demuxer.cc(1258)] pts: 0
[1:9:0728/153128:ERROR:audio_discard_helper.cc(222)] End discard of 960 out of 960
[1:9:0728/153128:ERROR:ffmpeg_demuxer.cc(1258)] pts: 1
[1:9:0728/153128:ERROR:audio_discard_helper.cc(222)] End discard of 960 out of 960
[1:9:0728/153128:ERROR:ffmpeg_demuxer.cc(1258)] pts: 2
[1:9:0728/153128:ERROR:audio_discard_helper.cc(222)] End discard of 960 out of 960
<snip>

At first I thought out test clip was muxed incorrectly, but as you can see from the report creating an ogg opus file using ToT will result in the same issues. Since increasing the seek time seems to "fix" the issue, I'd guess that seeking isn't properly finding the beginning of the stream.

Attachments (1)

sfx_f32le.wav (49.8 KB ) - added by Dale Curtis 6 years ago.
Wave source file for opus encoding.

Download all attachments as: .zip

Change History (3)

by Dale Curtis, 6 years ago

Attachment: sfx_f32le.wav added

Wave source file for opus encoding.

comment:1 by Michael Niedermayer, 6 years ago

Reproduced by developer: set
Resolution: fixed
Status: newclosed

comment:2 by Michael Niedermayer, 6 years ago

Cc: Michael Niedermayer added; michaelni removed
Note: See TracTickets for help on using tickets.