Opened 5 years ago

Closed 5 years ago

#469 closed defect (duplicate)

Undefined symbols for architecture x86_64: referenced from: _filter in libavfilter.a(vf_fspp.o)

Reported by: Alex__ Owned by:
Priority: normal Component: build system
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Description: Undefined symbols for architecture x86_64 referenced from: _filter in libavfilter.a(vf_fspp.o)
Version: a30ef633546ecf382d1913159870bd74649c680f (latest trunk)

Steps that will reproduce the problem?

  1. git clone --recursive --depth 1 git://git.videolan.org/ffmpeg.git
  2. cd ffmpeg
  3. ./configure --enable-libfaac --enable-libx264 --enable-gpl --enable-nonfree --enable-libmp3lame --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libxvid > b.log 2>&1 4. make -j3

What is the expected result?
Compiled binaries.

What happens instead?

MAN     doc/ffserver.1
CC      ffmpeg.o
ffmpeg.c: In function ‘opt_input_file’:
ffmpeg.c:3089: warning: ‘loop_input’ is deprecated (declared at libavformat/avformat.h:795)
ffmpeg.c: In function ‘opt_output_file’:
ffmpeg.c:3702: warning: ‘loop_output’ is deprecated (declared at libavformat/avformat.h:771)
CC      cmdutils.o
LD      ffmpeg_g
Undefined symbols for architecture x86_64:
  "_MM_FIX_0_707106781", referenced from:
      _filter in libavfilter.a(vf_fspp.o)
  "_MM_FIX_0_541196100", referenced from:
      _filter in libavfilter.a(vf_fspp.o)
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status
make: *** [ffmpeg_g] Error 1

Possible workaround:
Run configure without parameters.

Any additional information:
See attached.

Attachments (1)

compile.zip (24.7 KB) - added by Alex__ 5 years ago.
Build log files and shell scripts

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by Alex__

Build log files and shell scripts

comment:1 Changed 5 years ago by Alex__

Adding the parameter " --cc=clang" to the configure command fixes the issue with OS X 10.7.1 / Xcode 4.1 (thanks Carl). It might be interesting in this context that the libav repository compiles without modifying the compile parameters.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #353

Note: See TracTickets for help on using tickets.