Opened 4 years ago

Closed 4 years ago

#4570 closed enhancement (fixed)

Support SecureTransport for TLS on iOS / OS X

Reported by: chrisballinger Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: tls osx
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

This allows supporting TLS without relying on OpenSSL or gnutls on iOS and OS X which can greatly simplify the build process, especially on iOS.

There was a patch submitted to the mailing list: https://ffmpeg.org/pipermail/ffmpeg-devel/2015-May/172663.html

I tested the patch briefly and it seems to work properly, but requires setting --enable-securetransport instead of being autodetected.

Change History (5)

comment:1 Changed 4 years ago by cehoyos

  • Keywords securetransport apple ios osx removed

I would like to understand this ticket: Did you just open it to tell us you tested a patch or are you reporting an issue with FFmpeg?

comment:2 Changed 4 years ago by chrisballinger

  • Priority changed from normal to wish

comment:3 Changed 4 years ago by chrisballinger

It's a feature request, however, I found this pre-existing patch works well.

I couldn't find a good way to reply to the existing post on the mailing list because I wasn't a member of the mailing list when the patch was posted. However, it looks like the patch author just posted a new version of the patch that fixes SecureTransport? autodetection.

comment:4 Changed 4 years ago by cehoyos

  • Keywords osx added

comment:5 Changed 4 years ago by chrisballinger

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.