Opened 4 years ago

Closed 4 years ago

#4558 closed defect (invalid)

Compilation failure for the debug target

Reported by: epoitier Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: nfxjfg@googlemail.com Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

The flag we use to cause this issue to happen is -DDEBUG -g.

The compilation failure happen in two different files in libavcodec and you may find attached the patch to fix the issue.

Attachments (1)

ffmpeg-patch.zip (805 bytes) - added by epoitier 4 years ago.
Patch to apply to fix compilation errors in debug

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by epoitier

Patch to apply to fix compilation errors in debug

comment:1 Changed 4 years ago by cehoyos

  • Component changed from avcodec to undetermined
  • Priority changed from important to normal
  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 4 years ago by epoitier

Hi,

can we know the reason it is set to invalid ?

Best regards,
Emmanuel Poitier

comment:3 Changed 4 years ago by epoitier

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 Changed 4 years ago by gjdfgh

  • Cc nfxjfg@googlemail.com added

My guess is that cehoyos is mad because of something.

comment:5 Changed 4 years ago by epoitier

All,

hope I have not offended anyone. Will wait on Carl Eugen Hoyos feedback.

Best regards,
Emmanuel Poitier

comment:6 Changed 4 years ago by gjdfgh

Possibly it's because you ignored the "Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker." text when creating the ticket. Indeed, we usually prefer to see the patches on the mailing list.

comment:7 Changed 4 years ago by epoitier

Sorry then, but how a newbie would know ;)

I'll do that then, but still wondering why having a bug tracker ;)

comment:8 Changed 4 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.