Opened 3 years ago

Closed 2 years ago

#4430 closed defect (needs_more_info)

ffmpeg creates duplicate frames at begin of avi file

Reported by: martinr92 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

When I encode a video (source .avi, destination .avi), the destination files first 3 frames are equal.
I used following command to create the "out.avi":

ffmpeg -ss 00:00:02.360 -i "input.avi" -c:v libx264 -t 00:00:05.760 "out.avi"

Create thumbnails for the first 4 frames. You can see, that img1, img2 and img3 are equal:

ffmpeg -ss 00:00:00.000 -i out.avi -vcodec mjpeg -vframes 1 img1.jpg
ffmpeg -ss 00:00:00.040 -i out.avi -vcodec mjpeg -vframes 1 img2.jpg
ffmpeg -ss 00:00:00.080 -i out.avi -vcodec mjpeg -vframes 1 img3.jpg
ffmpeg -ss 00:00:00.120 -i out.avi -vcodec mjpeg -vframes 1 img4.jpg

If I encode the same video to a mp4, it's working correctly.

ffmpeg -ss 00:00:02.360 -i "input.avi" -c:v libx264 -t 00:00:05.760 "out.mp4"

The equal frames are a problem for me, because I create a lot of .avi files and merge them at the end. And caused by that duplicate frames, you can see a short "freeze" in the main video.

Change History (3)

comment:1 Changed 3 years ago by cehoyos

Please provide the command line that allows to reproduce the issue together with the complete, uncut console output to make this a valid ticket and provide an input sample.

comment:2 Changed 2 years ago by kolpax

I will add a link to one of the files I can reproduce it with soon.

comment:3 Changed 2 years ago by cehoyos

  • Component changed from ffmpeg to undetermined
  • Resolution set to needs_more_info
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.