Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4414 closed defect (invalid)

FFMPEG.EXE and all software packages written around it crash on my computers.

Reported by: mstrait Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
executing mp42avi, mp4cam2avi, ffmpeg, etc. crashes.

How to reproduce:
run any package or just "ffmpeg.exe" from command line

Additional information:

ffmpeg version N-63911-g3a1c895
built on Jun 12 2014 01:57:23 with gcc 4.8.1 (GCC)
configuration: --pkg-config=pkg-config --prefix=/home/jacek/ff/packages/win32 --enable-memalign-hack --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --enable-gpl --enable-version3 --disable-w32threads --disable-shared --enable-static --extra-cflags=-DPTW32_STATIC_LIB --enable-zlib --enable-libx264 --enable-libxvid --enable-libmp3lame --enable-libfaac
libavutil 52. 89.100 / 52. 89.100
libavcodec 55. 66.100 / 55. 66.100
libavformat 55. 43.100 / 55. 43.100
libavdevice 55. 13.101 / 55. 13.101
libavfilter 4. 8.100 / 4. 8.100
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 19.100 / 0. 19.100
libpostproc 52. 3.100 / 52. 3.100

I have been unable to find hardware requirements for ffmpeg.

I'm guessing ffmpeg is just incompatible with my 200MHz Pentium MMX processor in my Gateway Solo 2300 and 166MHz Pentium MMX processor in my IBM340 desktop.

I have no problems on the Pentium III computer at work.

I would greatly appreciate a reply by email

Following is an excerpt from the error report generated by Windows XP:

Exception Information
Code: 0xc000001d Flags: 0x00000000
Record: 0x0000000000000000 Address: 0x0000000000401300

System Information
Windows NT 5.1 Build: 2600
CPU Vendor Code: 756E6547 - 49656E69 - 6C65746E
CPU Version: 00000581 CPU Feature Code: 008001BF
CPU AMD Feature Code: 00D1E824

Module 1
ffmpeg.exe
Image Base: 0x00400000 Image Size: 0x00000000
Checksum: 0x00000000 Time Stamp: 0x5398ece8
Version Information

Signature: 00000000
StrucVer?: 00000000
FileVer?: (0.0:0.0)
ProdVer?: (0.0:0.0)
FlagMask?: 00000000
Flags: 00000000
OS: 00000000
FileType?: 00000000
SubType?: 00000000
FileDate?: 00000000:00000000

Module 2
ntdll.dll
Image Base: 0x7c900000 Image Size: 0x00000000
Checksum: 0x000b62bc Time Stamp: 0x4802a12c
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 3
kernel32.dll
Image Base: 0x7c800000 Image Size: 0x00000000
Checksum: 0x000f44a2 Time Stamp: 0x4802a12c
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 4
ADVAPI32.dll
Image Base: 0x77dd0000 Image Size: 0x00000000
Checksum: 0x0009b625 Time Stamp: 0x4802a0b2
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 5
RPCRT4.dll
Image Base: 0x77e70000 Image Size: 0x00000000
Checksum: 0x00091932 Time Stamp: 0x4802a106
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 6
Secur32.dll
Image Base: 0x77fe0000 Image Size: 0x00000000
Checksum: 0x000117db Time Stamp: 0x4802a11b
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 7
AVICAP32.DLL
Image Base: 0x73b80000 Image Size: 0x00000000
Checksum: 0x00016575 Time Stamp: 0x3b7dfe25
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.0)
ProdVer?: (5.1:2600.0)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 8
USER32.dll
Image Base: 0x7e410000 Image Size: 0x00000000
Checksum: 0x0008fc76 Time Stamp: 0x4802a11b
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 9
GDI32.dll
Image Base: 0x77f10000 Image Size: 0x00000000
Checksum: 0x000472ff Time Stamp: 0x4802a0be
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Module 10
WINMM.dll
Image Base: 0x76b40000 Image Size: 0x00000000
Checksum: 0x000316ef Time Stamp: 0x4802a13c
Version Information

Signature: feef04bd
StrucVer?: 00010000
FileVer?: (5.1:2600.5512)
ProdVer?: (5.1:2600.5512)
FlagMask?: 0000003f
Flags: 00000000
OS: 00040004
FileType?: 00000002
SubType?: 00000000
FileDate?: 00000000:00000000

Change History (2)

comment:1 Changed 3 years ago by 11rcombs

  • Resolution set to invalid
  • Status changed from new to closed

That's an illegal instruction; it probably indicates that the executable used SSE or some other extension that your CPU doesn't support. This is most likely due to you using a build of ffmpeg meant for newer processors; try building it yourself using -march=native or the equivalent arg for your compiler; reopen this ticket if the issue persists.

Also, note that while as far as I'm aware nobody's officially deprecated support for pre-SSE CPUs and Windows XP, you might have a hard time finding anyone willing to work on fixes for either.

comment:2 Changed 3 years ago by cehoyos

Could you test the following configure line?

$ ./configure --arch=x86 --target-os=mingw32 --cross-prefix=i686-w64-mingw32- --disable-w32threads --disable-pthreads --disable-zlib --disable-bzlib --extra-cflags=-DPTW32_STATIC_LIB

Does it change anything?

Note: See TracTickets for help on using tickets.