Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4400 closed defect (fixed)

Problems switching bit depth in input file

Reported by: electron.rotoscope Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: dnxhd regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Some editing systems such as Avid Media Composer will routinely create quicktime files that have some frames yuv422p and some frames yuv422p10le in the same file. When ffmpeg tries to encode video from these files it creates different glitches depending on unknown factors, but usually the result is not clean video.
Sample source file with on-screen text showing the changing bit depth available at http://electronrotoscope.com/ffmpeg/cartest_supers.mov and without onscreen text at http://electronrotoscope.com/ffmpeg/cartest_clean.mov

% ffmpeg.exe -i D:\cartest_supers.mov -pix_fmt yuv420p -vcodec libx264 -crf 24 -an D:\outvid.mp4
ffmpeg version N-71102-g1f5d1ee
built on 2015-03-28

Sample encode loglevel sandard http://pastebin.com/M7q5qhux
Sample encode loglevel debug http://pastebin.com/yBZcLuPU

Change History (3)

comment:1 Changed 5 years ago by electron.rotoscope

I don't know if this pastebin is any different but it's -v 9 -loglevel 99 http://pastebin.com/Mg3VSEws

Sorry about the double-upload, browser malfunction.
Also I should note the errors always seem to be at the point of switchover

Last edited 5 years ago by electron.rotoscope (previous) (diff)

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords dnxhd regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Regression since 64e7cf12 - should be fixed in dcac15a8
Thank you for the report!

For future tickets: Please do not use external resources (like pastebin), always post all necessary information here on the bug tracker. Please do not upload output files, this nearly always leads to confusion, just write that the issue is a regression (worked with version xyz).

comment:3 Changed 5 years ago by electron.rotoscope

I'll keep that in mind, thank you! Wow this will really help, I wish I'd reported it sooner!
I actually didn't know that it ever worked properly, I've never tried it in an ffmpeg that didn't have an error at the switchover point.

Note: See TracTickets for help on using tickets.