Opened 4 years ago

Closed 3 years ago

#4382 closed defect (needs_more_info)

Incorrect channel mapping when encoding dca/dts stream (Front C -> Front R)

Reported by: Drag0nFly Owned by:
Priority: normal Component: undetermined
Version: 2.6 Keywords: dca
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
=============

When encoding to 5.1 DTS, the center channel is mapped to the right speaker. Issue verified with v2.6.0 & v2.6.1 on OSX, as well as a custom-built version from git (N-67986-g79f77ce) on Linux (in an attempt to rule out any recent regression.)

The same input file has been tested on both systems encoding to 5.1-channel AC3/Dolby Digital, and the channel placements are correct. So the decoding stage is working properly, the encoding stage is not.

How to reproduce:

Process any file with a DTS core (1.5Mbps) track from dts->dts/dca. In my case I used a volume adjustment (as the source was not 0dBFS). I doubt if this makes a difference, however.

$ ffmpeg -i <input>.mkv -map 0 -c:v:0 copy -c:a:0 dts -strict -2 -af volume=+5.6dB -c:s copy <output>.mkv

FFmpeg version info:
=============

OSX (version obtained from Homebrew): ffmpeg version 2.6.1 Copyright (c) 2000-2015 the FFmpeg developers

built with Apple LLVM version 6.0 (clang-600.0.57) (based on LLVM 3.5svn)
configuration: --prefix=/usr/local/Cellar/ffmpeg/2.6.1 --enable-shared --enable-pthreads --enable-gpl --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-libx264 --enable-libmp3lame --enable-libvo-aacenc --enable-libxvid --enable-vda
libavutil 54. 20.100 / 54. 20.100
libavcodec 56. 26.100 / 56. 26.100
libavformat 56. 25.101 / 56. 25.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 11.102 / 5. 11.102
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100

Linux: ffmpeg version N-67986-g79f77ce Copyright (c) 2000-2014 the FFmpeg developers

built on Nov 25 2014 12:44:58 with gcc 4.7 (Ubuntu/Linaro? 4.7.3-1ubuntu1)
configuration: --prefix=/usr/local --enable-nonfree --enable-gpl --enable-libx264 --enable-libmp3lame --enable-libvorbis
libavutil 54. 15.100 / 54. 15.100
libavcodec 56. 13.100 / 56. 13.100
libavformat 56. 15.100 / 56. 15.100
libavdevice 56. 3.100 / 56. 3.100
libavfilter 5. 2.103 / 5. 2.103
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100

Source file excerpt (and resulting FFmpeg-processed dts excerpt) can be provided if needed.

Change History (1)

comment:1 Changed 3 years ago by cehoyos

  • Keywords dts channel mapping removed
  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if the issue is reproducible with current FFmpeg git head and if you can provide an input sample file.

Note: See TracTickets for help on using tickets.