Opened 4 years ago

Last modified 3 years ago

#4379 new defect

paket loss with rtp via udp

Reported by: richard_wang Owned by:
Priority: normal Component: undetermined
Version: 2.6 Keywords: rtp via udp packet loss
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When I use udp for rtp communication, I got lot of "rtp: missed packet", and the video output is full of mosaic.

How to reproduce:
With ffmpeg-2.3, I work with VLC as rtsp server. Stream a mp4 file through rtsp without transcoding. On the client side, try below command:
ffplay "rtsp://192.168.112.21/rtsph2641080p"

The can see the sympton.

I tried to search in the forum, and found it similar to #258, #257, and #285. But even I tried to disable inside udp.c HAVE_PTHREAD_CANCEL, it does not help.

Thanks in advance for any suggestion.

% ffmpeg -i input ... output
ffmpeg version
built on ...

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.

Change History (3)

comment:1 Changed 4 years ago by richard_wang

  • Version changed from unspecified to 2.6

comment:2 Changed 3 years ago by thovo

  • Summary changed from paket loss iwth rtp via udp to paket loss with rtp via udp

comment:3 Changed 3 years ago by thovo

Do you have the same problem when both server and client run on the same host?

Note: See TracTickets for help on using tickets.