Opened 5 years ago

Closed 5 years ago

#436 closed defect (invalid)

ffplay disables DPMS timeouts; no way to re-enable them during play

Reported by: tpavlic Owned by: michael
Priority: normal Component: ffplay
Version: git-oldabi Keywords: DPMS
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: yes


ffplay (and mplayer) appears to disable DPMS timeouts while it runs. I can verify that "xset q" shows that DPMS is enabled and timeouts are set correctly; however, so long as ffplay (or mplayer) are open, monitors refuse to sleep.

With mplayer, I can at least issue an "xset dpms force off" and the monitors will turn off and stay off, but standby and suspend are impossible (monitors pop back on). With ffplay, even "xset dpms force off" causes monitors to pop back on.

I can understand why this is a desirable behavior for playing movies. However, some applications (e.g., the electricsheep screen saver) are not deteriorated by allowing monitors to sleep. So there should be a way to turn off this DPMS-dodging feature of ffplay (and mplayer).

Change History (3)

comment:1 Changed 5 years ago by michael

  • Analyzed by developer set

ffplay isnt at fault, its sdl
if you set the "SDL_VIDEO_ALLOW_SCREENSAVER" environment variable to 1 then the screesaver should activate normally

comment:2 Changed 5 years ago by tpavlic

I can confirm that SDL_VIDEO_ALLOW_SCREENSAVER restores the expected behavior. ffplay is not at fault. This ticket can be closed. Thanks.

(FYI, the similar problem in mplayer is due to a bug discovered today that was making "nostop-xscreensaver" not do anything. That is, "stop-xscreensaver" was always asserted. Once the single line of code is checked in that fixes that problem, then mplayer won't have this issue either)

comment:3 Changed 5 years ago by michael

  • Resolution set to invalid
  • Status changed from new to closed

ok, then iam closing it

Note: See TracTickets for help on using tickets.