Opened 4 years ago

Closed 4 years ago

#4318 closed defect (needs_more_info)

vp8 rtsp copy stream not working

Reported by: yurivale Owned by:
Priority: normal Component: undetermined
Version: 2.5.2 Keywords: rtsp, webm, vp8
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I am trying to send and receive a webm file (only video) through a rtsp tcp tunnel with the following command line, but the receiver part produces an empty file:

Receiver site:

C:\temp\recv>ffmpeg -v 9 -loglevel 99 -report -y -f rtsp -rtsp_flags listen -rtsp_transport tcp -i rtsp://127.0.0.1:23020/live.sdp -vcodec copy -an out.webm

Transmit site:

C:\temp>ffmpeg -v 9 -loglevel 99 -report -i small.webm -vcodec copy -an -f rtsp -rtsp_transport tcp rtsp://127.0.0.1:23020/live.sdp

The same, but with mp4 files, instead is (correctly) working.

Receiver site:

C:\temp\recv>ffmpeg -v 9 -loglevel 99 -report -y -f rtsp -rtsp_flags listen -rtsp_transport tcp -i rtsp://127.0.0.1:23020/live.sdp -vcodec copy -an out.mp4

Transmit site:

C:\temp>ffmpeg -v 9 -loglevel 99 -report -i small.mp4 -vcodec copy -an -f rtsp -rtsp_transport tcp rtsp://127.0.0.1:23020/live.sdp
ffmpeg version 2.5.2
built on Dec 30 2014 17:29:04 with gcc 4.9.2 (GCC)
zeranoe build

Attachments (8)

rx-webm-ffmpeg-20150220-144813.log (5.6 KB) - added by yurivale 4 years ago.
webm receiver site
tx-webm-ffmpeg-20150220-144815.log (5.1 KB) - added by yurivale 4 years ago.
webm transmitter file
small.webm (224.1 KB) - added by yurivale 4 years ago.
webm input file
out.webm (440 bytes) - added by yurivale 4 years ago.
webm output file
rx-mp4-ffmpeg-20150220-144632.log (6.4 KB) - added by yurivale 4 years ago.
mp4 receiver site
tx-mp4-ffmpeg-20150220-144637.log (17.0 KB) - added by yurivale 4 years ago.
mp4 transmitter site
small.mp4 (374.6 KB) - added by yurivale 4 years ago.
mp4 input file
out.mp4 (316.0 KB) - added by yurivale 4 years ago.
mp4 output file

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by yurivale

webm receiver site

Changed 4 years ago by yurivale

webm transmitter file

Changed 4 years ago by yurivale

webm input file

Changed 4 years ago by yurivale

webm output file

Changed 4 years ago by yurivale

mp4 receiver site

Changed 4 years ago by yurivale

mp4 transmitter site

Changed 4 years ago by yurivale

mp4 input file

Changed 4 years ago by yurivale

mp4 output file

comment:1 Changed 4 years ago by yurivale

Using -dump option, looks like ffmpeg is not recognizing key frames (even the initial) in vp8 stream, so the copy stream is not starting.
Using -copyinkf option, overrides this behavior and the resulting file is correct.

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can reproduce the issue with current FFmpeg git head or if you believe that this is a regression.

Note: See TracTickets for help on using tickets.