Opened 6 years ago

Closed 5 years ago

#4218 closed defect (fixed)

regression: jpeg output streams instead of shows image

Reported by: illumilore Owned by:
Priority: important Component: ffserver
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no


When using ffservres jpeg output, the actual jpeg image streams instead of just showing the image.

Summary of the bug:
How to reproduce:

% ffmpeg -i input ... output
ffmpeg version
built on ...

Patches should be submitted to the ffmpeg-devel mailing list and not this bug tracker.
<Stream test.jpg>

Feed cam.ffm
Format jpeg
VideoFrameRate? 2
VideoQmin? 1
VideoQMax 5
VideoSize? 960x720
Strict -1


$ ffmpeg --version
ffmpeg version 2.3.3 Copyright (c) 2000-2014 the FFmpeg developers

built on Nov 14 2014 12:17:00 with gcc 4.8 (SUSE Linux)
configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --disable-static --enable-debug --disable-stripping --extra-cflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm' --enable-gpl --enable-x11grab --enable-version3 --enable-pthreads --enable-avfilter --enable-libpulse --enable-libvpx --enable-libopus --enable-libass --enable-libx265 --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-libx264 --enable-libschroedinger --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-postproc --enable-libdc1394 --enable-librtmp --enable-libfreetype --enable-avresample --enable-libtwolame --enable-libvo-aacenc --enable-gnutls
libavutil 52. 92.100 / 52. 92.100
libavcodec 55. 69.100 / 55. 69.100
libavformat 55. 48.100 / 55. 48.100
libavdevice 55. 13.102 / 55. 13.102
libavfilter 4. 11.100 / 4. 11.100
libavresample 1. 3. 0 / 1. 3. 0
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 19.100 / 0. 19.100
libpostproc 52. 3.100 / 52. 3.100

Change History (5)

comment:1 Changed 5 years ago by illumilore

  • Priority changed from normal to important
  • Version changed from unspecified to git-master

comment:2 Changed 5 years ago by michael

You say this is a regression, which commit caused this regression ?
(you can find it with git bisect)

comment:3 Changed 5 years ago by illumilore

IIRC, when I last tried older versions of ffmpeg, nothing from before around 2010 builds would work. It complained about some library, so I cant figure out which one it was.

comment:4 Changed 5 years ago by illumilore

I have a patch that works and have tried submitting it the email list, but noone there committed it or seems to want it fixed, I guess.

comment:5 Changed 5 years ago by michael

  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.