Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4193 closed defect (invalid)

ffmpeg crash

Reported by: vipjml Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: libvo-aac
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
How to reproduce:

ffmpeg-git-20141216-64bit-static/ffmpeg -report -i Ticket\ #4192.mp4 -ar 44100  -b:a 48k output.mp4
ffmpeg started on 2014-12-17 at 14:26:46
Report written to "ffmpeg-20141217-142646.log"
ffmpeg version N-42969-g92a596f-   http://johnvansickle.com/ffmpeg/    Copyright (c) 2000-2014 the FFmpeg developers
  built on Dec 16 2014 01:24:53 with gcc 4.8 (Debian 4.8.3-16)
  configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc-4.8
  libavutil      54. 15.100 / 54. 15.100
  libavcodec     56. 15.100 / 56. 15.100
  libavformat    56. 15.105 / 56. 15.105
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  3.101 /  5.  3.101
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Ticket #4192.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 1970-01-01 00:00:00
    encoder         : Lavf52.84.0
  Duration: 00:45:21.03, start: 0.000000, bitrate: 749 kb/s
    Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 480x320 [SAR 1:1 DAR 3:2], 699 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 43 kb/s (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : SoundHandler
[libx264 @ 0x325b8a0] using SAR=1/1
[libx264 @ 0x325b8a0] using cpu capabilities: MMX2 SSE Cache64
[libx264 @ 0x325b8a0] profile High, level 2.1
[libx264 @ 0x325b8a0] 264 - core 142 r62 24e4fed - H.264/MPEG-4 AVC codec - Copyleft 2003-2014 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=12 lookahead_threads=2 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'output.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf56.15.105
    Stream #0:0(und): Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 480x320 [SAR 1:1 DAR 3:2], q=-1--1, 25 fps, 12800 tbn, 25 tbc (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : VideoHandler
      encoder         : Lavc56.15.100 libx264
    Stream #0:1(und): Audio: aac (libvo_aacenc) ([64][0][0][0] / 0x0040), 44100 Hz, stereo, s16, 48 kb/s (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : SoundHandler
      encoder         : Lavc56.15.100 libvo_aacenc
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (aac (native) -> aac (libvo_aacenc))
Press [q] to stop, [?] for help
Segmentation fault5 q=28.0 size=   19740kB time=00:30:55.16 bitrate=  87.2kbits/s    
[root@CDN video_segments]# rm output.mp4 
rm: remove regular file `output.mp4'? y
[root@CDN video_segments]# ffmpeg-git-20141216-64bit-static/ffmpeg -report -i Ticket\ #4192.mp4 -ar 44100  -b:a 48k output.mp4
ffmpeg started on 2014-12-17 at 14:30:55
Report written to "ffmpeg-20141217-143055.log"
ffmpeg version N-42969-g92a596f-   http://johnvansickle.com/ffmpeg/    Copyright (c) 2000-2014 the FFmpeg developers
  built on Dec 16 2014 01:24:53 with gcc 4.8 (Debian 4.8.3-16)
  configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc-4.8
  libavutil      54. 15.100 / 54. 15.100
  libavcodec     56. 15.100 / 56. 15.100
  libavformat    56. 15.105 / 56. 15.105
  libavdevice    56.  3.100 / 56.  3.100
  libavfilter     5.  3.101 /  5.  3.101
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  3.100 / 53.  3.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'Ticket #4192.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    creation_time   : 1970-01-01 00:00:00
    encoder         : Lavf52.84.0
  Duration: 00:45:21.03, start: 0.000000, bitrate: 749 kb/s
    Stream #0:0(und): Video: h264 (Constrained Baseline) (avc1 / 0x31637661), yuv420p, 480x320 [SAR 1:1 DAR 3:2], 699 kb/s, 25 fps, 25 tbr, 25 tbn, 50 tbc (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : VideoHandler
    Stream #0:1(und): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 43 kb/s (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : SoundHandler
[libx264 @ 0x36198a0] using SAR=1/1
[libx264 @ 0x36198a0] using cpu capabilities: MMX2 SSE Cache64
[libx264 @ 0x36198a0] profile High, level 2.1
[libx264 @ 0x36198a0] 264 - core 142 r62 24e4fed - H.264/MPEG-4 AVC codec - Copyleft 2003-2014 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deblock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 me_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-2 threads=12 lookahead_threads=2 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1 b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'output.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 512
    compatible_brands: isomiso2avc1mp41
    encoder         : Lavf56.15.105
    Stream #0:0(und): Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 480x320 [SAR 1:1 DAR 3:2], q=-1--1, 25 fps, 12800 tbn, 25 tbc (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : VideoHandler
      encoder         : Lavc56.15.100 libx264
    Stream #0:1(und): Audio: aac (libvo_aacenc) ([64][0][0][0] / 0x0040), 44100 Hz, stereo, s16, 48 kb/s (default)
    Metadata:
      creation_time   : 1970-01-01 00:00:00
      handler_name    : SoundHandler
      encoder         : Lavc56.15.100 libvo_aacenc
Stream mapping:
  Stream #0:0 -> #0:0 (h264 (native) -> h264 (libx264))
  Stream #0:1 -> #0:1 (aac (native) -> aac (libvo_aacenc))
Press [q] to stop, [?] for help
Segmentation fault7 q=28.0 size=   19722kB time=00:30:53.51 bitrate=  87.2kbits/s 

"Ticket #4192.mp4" have been uploaded to ftp://upload.ffmpeg.org/incoming

Attachments (1)

Ticket #4192.zip (346.9 KB) - added by vipjml 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by vipjml

ffmpeg-git-20141216-64bit-static/ffmpeg -report -i Ticket\ #4192.mp4 -ar 44100 -b:a 32k output.mp4 will work well

Changed 5 years ago by vipjml

comment:2 Changed 5 years ago by vipjml

"Ticket #4192.mp4"'s upload maybe failed. please use "Ticket #4193.mp4" instead! the file's md5 is 5b7ebb706aa7a128a16600059d666f77

comment:3 follow-up: Changed 5 years ago by cehoyos

  • Component changed from ffmpeg to undetermined

Please test with -an and -vn. If only -an allows to reproduce the issue, please test with -vcodec mpeg4 -qscale 2.

comment:4 in reply to: ↑ 3 Changed 5 years ago by vipjml

Replying to cehoyos:

Please test with -an and -vn. If only -an allows to reproduce the issue, please test with -vcodec mpeg4 -qscale 2.

"ffmpeg -report -i Ticket\ #4192.mp4 -vn -ar 44100 -b:a 48k output.mp4" crash
"ffmpeg -report -i Ticket\ #4192.mp4 -an -ar 44100 -b:a 48k output.mp4" no problem

comment:5 Changed 5 years ago by vipjml

i upload the mp4 without videopart Ticket#4193_NOVIDEO.mp4

comment:6 follow-ups: Changed 5 years ago by cehoyos

Then please test the following:
$ ffmpeg -i Ticket\ #4192.mp4 -strict -2 -acodec aac out1.aac
$ ffmpeg -i Ticket\ #4192.mp4 out2.aac

comment:7 in reply to: ↑ 6 Changed 5 years ago by vipjml

Replying to cehoyos:

Then please test the following:
$ ffmpeg -i Ticket\ #4192.mp4 -strict -2 -acodec aac out1.aac
$ ffmpeg -i Ticket\ #4192.mp4 out2.aac

both no problem
i also test:
"ffmpeg -report -i Ticket\ #4192.mp4 -vn -ar 44100 -b:a 32k output.mp4"
which not crash

comment:8 in reply to: ↑ 6 Changed 5 years ago by vipjml

Replying to cehoyos:

Then please test the following:
$ ffmpeg -i Ticket\ #4192.mp4 -strict -2 -acodec aac out1.aac
$ ffmpeg -i Ticket\ #4192.mp4 out2.aac

only crash with ar 44100 and b:a bigger than 45k(not exactly)

if set ar 48000 it work well

comment:9 follow-ups: Changed 5 years ago by cehoyos

  • Keywords libvo-aac added
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from unspecified to git-master

Workaround is to use the native encoder which has a better sound quality:
-strict -2 -acodec aac
Since the crash apparently happens in an external library and is not reproducible with all versions of libvo_aac (works fine here), I close this ticket as invalid. If you believe there is a bug in FFmpeg that can be fixed within FFmpeg, you would have to provide a backtrace etc. as explained on https://ffmpeg.org/bugreports.html

comment:10 in reply to: ↑ 9 Changed 5 years ago by vipjml

Replying to cehoyos:

Workaround is to use the native encoder which has a better sound quality:
-strict -2 -acodec aac
Since the crash apparently happens in an external library and is not reproducible with all versions of libvo_aac (works fine here), I close this ticket as invalid. If you believe there is a bug in FFmpeg that can be fixed within FFmpeg, you would have to provide a backtrace etc. as explained on https://ffmpeg.org/bugreports.html

i use the ffmpeg downloaded from http://johnvansickle.com/ffmpeg/
the defautl audio encoder is libvo-aacenc,i think it should be a bug of libvo-aacenc
i will compile ffmpeg and test later

comment:11 in reply to: ↑ 9 Changed 5 years ago by vipjml

Replying to cehoyos:

Workaround is to use the native encoder which has a better sound quality:
-strict -2 -acodec aac
Since the crash apparently happens in an external library and is not reproducible with all versions of libvo_aac (works fine here), I close this ticket as invalid. If you believe there is a bug in FFmpeg that can be fixed within FFmpeg, you would have to provide a backtrace etc. as explained on https://ffmpeg.org/bugreports.html

Thanks for you help. I will use -strict -2 -acodec aac which work well!

Note: See TracTickets for help on using tickets.