Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#4156 closed defect (worksforme)

libx264 check broken in 2.5 (ok in HEAD)

Reported by: nieder Owned by:
Priority: normal Component: build system
Version: 2.5 Keywords: libx264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

The configure check for libx264 in the 2.5 release is broken.

How to reproduce:

$ ./configure --enable-libx264 --enable-gpl
./configure: line 4915: syntax error near unexpected token `}'
./configure: line 4915: `                                 warn "using libx264 without pkg-config"; } } &&'

The check in configure from git HEAD is ok (uses use_pkg_config() as the first check attempt and is preceded by an opening `{' ).

Tested on OS X but this looks like it should be a universal failure.

Change History (5)

comment:1 Changed 3 years ago by michael

configure is identical between master/HEAD and release/2.5, also it works fine here on linux

comment:2 Changed 3 years ago by cehoyos

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen if you can add information about your system.

$ git checkout master
$ git pull
$ ./configure --enable-gpl --enable-libx264

...

WARNING: pkg-config not found, library detection may fail.
WARNING: using libx264 without pkg-config
$ git checkout n2.5
$ ./configure --enable-gpl --enable-libx264

...

WARNING: pkg-config not found, library detection may fail.
WARNING: using libx264 without pkg-config

comment:3 Changed 3 years ago by cehoyos

  • Keywords libx264 added

comment:4 Changed 3 years ago by cehoyos

  • Version changed from unspecified to 2.5

comment:5 Changed 3 years ago by nieder

Ugh. I had applied an unrelated test change to a different section in configure and accidentally screwed up the libx264 detection code. Sorry about the noise.

Note: See TracTickets for help on using tickets.