Opened 7 years ago

Closed 7 years ago

#413 closed defect (fixed)

error: implicit declaration of function 'strtok_r' [-Werror=implicit-function-declaration]

Reported by: KSHawkEye Owned by:
Priority: critical Component: build system
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm having troubles compiling FFmpeg for Windows. This error comes up:

/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c: In function 'init':
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:259:5: error: implicit declaration of function 'strtok_r' [-Werror=implicit-function-declaration]
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:259:9: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:271:5: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:272:5: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:273:5: warning: assignment makes pointer from integer without a cast [enabled by default]
/home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c:274:5: warning: assignment makes pointer from integer without a cast [enabled by default]
cc1: some warnings being treated as errors

Here is what V=1 shows:

i686-w64-mingw32-gcc -I. -I/home/kyle/software/ffmpeg/source/ffmpeg-git/ -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -U__STRICT_ANSI__ -DHAVE_AV_CONFIG_H -std=c99 -fno-common -fomit-frame-pointer -g -Wdeclaration-after-statement -Wall -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wno-pointer-sign -Wcast-qual -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wno-pointer-to-int-cast -O3 -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -Werror=implicit-function-declaration -Werror=missing-prototypes  -MMD -MF libavfilter/asrc_abuffer.d -MT libavfilter/asrc_abuffer.o -c -o libavfilter/asrc_abuffer.o /home/kyle/software/ffmpeg/source/ffmpeg-git/libavfilter/asrc_abuffer.c

Here is my configure:

cross_prefix=i686-w64-mingw32- target_os=mingw32 arch=x86 pkg_config=pkg-config ../source/ffmpeg-git/configure --enable-gpl --enable-version3 --enable-runtime-cpudetect

I've giving this critical priority because FFmpeg is unable to be built with MinGW-w64.

I'm using the latest FFmpeg.

Change History (1)

comment:1 Changed 7 years ago by cehoyos

  • Component changed from undetermined to build system
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from git to git-master

Should be fixed.

Did you report to the mingw64 developers that strtok_r (or its definition?) is missing?
I believe it is defined in Posix.

Note: See TracTickets for help on using tickets.