Opened 5 years ago

Closed 5 years ago

#4125 closed defect (worksforme)

MPEG4 remuxing

Reported by: Mista_D Owned by:
Priority: critical Component: avformat
Version: 2.4.3 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

MP4 file with MPEG4 part2 video track can not be converted to MPEG2-TS container by using "-c copy" command using FFmpeg 2.4.3.

Generate blank video track with time code burned in for reference, packaged to MP4:
ffmpeg243 -s 640x360 -f rawvideo -pix_fmt rgb24 -r 24 -i /dev/zero -t 100 -vf "drawtext=fontfile=/home/dennisp/arial.ttf:box=1:fontsize=64:timecode='00\\:00\\:00\\:00':rate=24" -pix_fmt yuv420p -c:v mpeg4 test1.mp4
OK.

Convert MP4 to TS:
ffmpeg243 -i test1.mp4 -c copy test1.ts
OK.

Test TS:
ffmpeg243 -i test1.ts -f null /dev/null
ERRORS HERE

ffmpeg version 2.4.3 Copyright (c) 2000-2014 the FFmpeg developers

built on Nov 18 2014 13:02:02 with gcc 4.1.2 (GCC) 20080704 (Red Hat 4.1.2-52)
configuration: --prefix=/home/dennisp/010_64 --enable-static --enable-postproc --enable-gpl --enable-avfilter --enable-libx264 --enable-libxvid --enable-libmp3lame --enable-libfdk-aac --enable-pthreads --enable-swscale --enable-runtime-cpudetect --disable-devices --disable-avdevice --extra-ldflags=-static --disable-shared --enable-bzlib --enable-zlib --enable-libfaac --extra-libs='-lx264 -lxvidcore -lmp3lame -lpthread -lm -lbz2 -lz -lpthread -lvpx -lass -lfontconfig -lexpat -lfreetype -lfdk-aac -lfaac' --disable-encoder=libgsm --disable-decoder=libgsm --disable-doc --enable-libvpx --enable-libass --enable-version3 --enable-nonfree --enable-libfreetype
libavutil 54. 7.100 / 54. 7.100
libavcodec 56. 1.100 / 56. 1.100
libavformat 56. 4.101 / 56. 4.101
libavfilter 5. 1.100 / 5. 1.100
libswscale 3. 0.100 / 3. 0.100
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 0.100 / 53. 0.100

Change History (4)

comment:1 Changed 5 years ago by Mista_D

Complete error log:
ffmpeg243 -i test1.ts -f null /dev/null
ffmpeg version 2.4.3 Copyright (c) 2000-2014 the FFmpeg developers

built on Nov 18 2014 13:02:02 with gcc 4.1.2 (GCC) 20080704 (Red Hat 4.1.2-52)
configuration: --prefix=/home/dennisp/010_64 --enable-static --enable-postproc --enable-gpl --enable-avfilter --enable-libx264 --enable-libxvid --enable-libmp3lame --enable-libfdk-aac --enable-pthreads --enable-swscale --enable-runtime-cpudetect --disable-devices --disable-avdevice --extra-ldflags=-static --disable-shared --enable-bzlib --enable-zlib --enable-libfaac --extra-libs='-lx264 -lxvidcore -lmp3lame -lpthread -lm -lbz2 -lz -lpthread -lvpx -lass -lfontconfig -lexpat -lfreetype -lfdk-aac -lfaac' --disable-encoder=libgsm --disable-decoder=libgsm --disable-doc --enable-libvpx --enable-libass --enable-version3 --enable-nonfree --enable-libfreetype
libavutil 54. 7.100 / 54. 7.100
libavcodec 56. 1.100 / 56. 1.100
libavformat 56. 4.101 / 56. 4.101
libavfilter 5. 1.100 / 5. 1.100
libswscale 3. 0.100 / 3. 0.100
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 0.100 / 53. 0.100

[mpeg4 @ 0x16a15ea0] hmm, seems the headers are not complete, trying to guess time_increment_bits
[mpeg4 @ 0x16a15ea0] my guess is 5 bits ;)
[mpeg4 @ 0x16a15ea0] hmm, seems the headers are not complete, trying to guess time_increment_bits
[mpeg4 @ 0x16a15ea0] my guess is 5 bits ;)
[mpeg4 @ 0x16a15ea0] looks like this file was encoded with (divx4/(old)xvid/opendivx) -> forcing low_delay flag
[mpeg4 @ 0x16a15ea0] [IMGUTILS @ 0x7fff3a12b1b0] Picture size 0x0 is invalid
[mpeg4 @ 0x16a15ea0] video_get_buffer: image parameters invalid
[mpeg4 @ 0x16a15ea0] get_buffer() failed
[mpeg4 @ 0x16a15ea0] thread_get_buffer() failed
[mpeg4 @ 0x16a15ea0] get_buffer() failed (-22 (nil))
[mpeg4 @ 0x16a15ea0] releasing zombie picture
[mpeg4 @ 0x16a15ea0] [IMGUTILS @ 0x7fff3a12b1b0] Picture size 0x0 is invalid
[mpeg4 @ 0x16a15ea0] video_get_buffer: image parameters invalid
[mpeg4 @ 0x16a15ea0] get_buffer() failed

#EDIT removed repeating messages

[mpeg4 @ 0x16a15ea0] [IMGUTILS @ 0x7fff3a12b1b0] Picture size 0x0 is invalid
[mpeg4 @ 0x16a15ea0] video_get_buffer: image parameters invalid
[mpeg4 @ 0x16a15ea0] get_buffer() failed
[mpeg4 @ 0x16a15ea0] thread_get_buffer() failed
[mpeg4 @ 0x16a15ea0] get_buffer() failed (-22 (nil))
[mpegts @ 0x16a11fe0] decoding for stream 0 failed
[mpegts @ 0x16a11fe0] Could not find codec parameters for stream 0 (Video: mpeg4 ([16][0][0][0] / 0x0010), yuv420p): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
test1.ts: could not find codec parameters
Input #0, mpegts, from 'test1.ts':

Duration: 00:01:40.00, start: 1.400000, bitrate: 260 kb/s
Program 1

Metadata:

service_name : Service01
service_provider: FFmpeg

Stream #0:0[0x100]: Video: mpeg4 ([16][0][0][0] / 0x0010), yuv420p, 24 fps, 24 tbr, 90k tbn, 90k tbc

Output #0, null, to '/dev/null':
Output file #0 does not contain any stream

Last edited 5 years ago by Mista_D (previous) (diff)

comment:2 Changed 5 years ago by Mista_D

  • Priority changed from normal to critical

comment:3 Changed 5 years ago by Mista_D

Adding "-bsf:v dump_extra" worked.
Thanks to Michael and google.
http://thread.gmane.org/gmane.comp.video.ffmpeg.user/4936

comment:4 Changed 5 years ago by Mista_D

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.