Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4098 closed defect (wontfix)

To what range is the swscaler referring to?

Reported by: michael.heuberger Owned by:
Priority: normal Component: swscale
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
When encoding the video, I always see this warning

[swscaler @ 0x2599be0] deprecated pixel format used, make sure you did set range correctly

I want this warning to disappear but how? I am already setting the recommended pixel format

{{
-pix_fmt yuv420p
}}

but the warning still shows up. I really do not understand to what range the swscaler is referring to. How can I fix this? Or is this a bug?

How to reproduce:

% ffmpeg -r 14.563322542394877 -f image2 -i /home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e4-686f-55c3c770-9cab-b5660842b8b4/frames/%d.jpg -i /home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e4-686f-55c3c770-9cab-b5660842b8b4/videomail_preview.wav -y -acodec libfdk_aac -ar 44100 -ac 1 -vcodec libx264 -preset ultrafast -profile:v baseline -crf 24 -pix_fmt yuv420p -loglevel warning -movflags faststart /home/michael-heuberger/binarykitchen/code/videomail.io/var/local/tmp/clients/videomail.io/11e4-686f-55c3c770-9cab-b5660842b8b4/videomail_preview.mp4
$ ffmpeg   
ffmpeg version 2.4.2 Copyright (c) 2000-2014 the FFmpeg developers
  built on Oct 10 2014 15:15:58 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
  configuration: --extra-libs=-ldl --prefix=/opt/ffmpeg --enable-avresample --disable-debug --enable-nonfree --enable-gpl --enable-version3 --enable-x11grab --enable-libpulse --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-decoder=amrnb --disable-decoder=amrwb --enable-libx264 --enable-libx265 --enable-libfdk-aac --enable-libvorbis --enable-libmp3lame --enable-libopus --enable-libvpx --enable-libspeex --enable-libass --enable-avisynth --enable-libsoxr --enable-libxvid
  libavutil      54.  7.100 / 54.  7.100
  libavcodec     56.  1.100 / 56.  1.100
  libavformat    56.  4.101 / 56.  4.101
  libavdevice    56.  0.100 / 56.  0.100
  libavfilter     5.  1.100 /  5.  1.100
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  0.100 /  3.  0.100
  libswresample   1.  1.100 /  1.  1.100
  libpostproc    53.  0.100 / 53.  0.100
Hyper fast Audio and Video encoder

Change History (7)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to wontfix
  • Status changed from new to closed

You cannot make the warning disappear for ffmpeg depending on your input or output pix_fmt.

comment:2 Changed 5 years ago by michael.heuberger

Ok, how can I find out the pix_fmt?

comment:3 Changed 5 years ago by cehoyos

It would be part of the console output if you had provided it.

Please understand that this is a bug tracker, not a support forum. Please consider asking all questions concerning FFmpeg on the user mailing list.

comment:4 follow-up: Changed 5 years ago by michael.heuberger

'-pix_fmt yuvj420p' did the trick for me

sorry about the question!

comment:5 in reply to: ↑ 4 Changed 5 years ago by cehoyos

Replying to michael.heuberger:

'-pix_fmt yuvj420p' did the trick for me

This unfortunately breaks your output file depending on the player you are using.
No warning is shown because you explicitly requested a possibly incompatible output pixel format.

comment:6 Changed 5 years ago by michael.heuberger

@cehoyos really? now i am confused. should i use yuvj420p or yuv420p? which one format is breaking which player?

comment:7 Changed 5 years ago by cehoyos

WMP only supports yuv420p.

Please move this discussion to the mailing list.

Note: See TracTickets for help on using tickets.