Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#406 closed defect (needs_more_info)

QuickTime Error: "Error -2041: an invalid sample description was found in the movie"

Reported by: KSHawkEye Owned by: michael
Priority: normal Component: avformat
Version: git-master Keywords: mov mp3
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

While trying to play back a simple video encoded with FFmpeg and lame, I get: "Error -2041: an invalid sample description was found in the movie"

I'm on a Windows machine and am unsure if the problem is just on Windows or on Linux too.

The command line I used was:

ffmpeg -i "input.mp4" -y -acodec libmp3lame -vn "output.mp4"

No errors were displayed while encoding.

I'm using version git-41bf67d built on 2011-08-16

mp3 should be accepted in a .mp4 container and QuickTime? should be able to play it back, so I believe this is an FFmpeg bug.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to avformat
  • Priority changed from important to normal
  • Status changed from new to open
  • Version changed from git to git-master

Compete, uncut output missing.

Do you believe this is a regression? If not, why do you think this is supposed to work? Do you have a mp3-in-isom sample that works with QuickTime??

(Works fine with -f mov)

comment:2 Changed 5 years ago by cehoyos

  • Keywords isom mp3 added
  • Resolution set to needs_more_info
  • Status changed from open to closed

Please reopen if an isom file with mp3 that can be played with QuickTime? is found.

comment:3 Changed 4 years ago by cehoyos

  • Keywords mov added; isom removed
Note: See TracTickets for help on using tickets.