Opened 4 years ago

Closed 4 years ago

#4031 closed defect (needs_more_info)

Serious memory leak

Reported by: tips2014 Owned by:
Priority: normal Component: undetermined
Version: 2.4.2 Keywords: leak
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

./ffmpeg_g -y -override_ffserver -i rtmp://192.168.14.170/live/rtsp301 -flags +global_header -codec copy http://192.168.14.170:8000/feed300.ffm
ffmpeg-2.4.4

More than half an hour memory starts to rise, more up faster. 10 hours long 100M

Change History (2)

comment:1 Changed 4 years ago by cehoyos

  • Cc Chinese god of Technology Co. Ltd. removed
  • Component changed from ffmpeg to undetermined
  • Keywords memory removed
  • Reproduced by developer unset

Please test current FFmpeg git head and please try if the issue is reproducible with file output or file input. Please provide the command line together with the complete, uncut console output.

If there is a leak, valgrind output (or similar) is required: Without it, we cannot know where the leak is.
Or do you want to report that a lot of memory is allocated (but no leak)?

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can add more information.

Note: See TracTickets for help on using tickets.