Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3997 closed defect (duplicate)

Endless loop when seeking past the end of an incomplete wtf file

Reported by: gjdfgh Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Start an incomplete wtv file with ffplay, and click close to the right border of the screen. Since the duration is apparently stored in the file header, doing this will seek past the end of the file. It will enter an endless loop in the demuxeR:

[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2455 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2470 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2478 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2500 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2513 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2480 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2519 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2552 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2588 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2505 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2505 times
[wtv @ 0x7fffd8000940] encountered broken chunkKB sq=  112B f=0/0   
    Last message repeated 2530 times

Get the sample file from https://app.box.com/s/ofjnj0vnqqgkojv545xa (not my upload).

Change History (5)

comment:1 Changed 4 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, I think two tickets (and a patch) are sufficient.

comment:2 Changed 4 years ago by gjdfgh

Sorry... #3991 looked different, but maybe they're the same issue. Or is this a duplicate of another ticket?

comment:3 Changed 4 years ago by cehoyos

Afaict, #3991, #3995 and this ticket describe the same issue but as I am already tired of testing it (this ticket does not look significantly better than #3991), please prove me wrong!

comment:4 Changed 4 years ago by gjdfgh

Your patch fixes it for me.

comment:5 Changed 4 years ago by cehoyos

Thank you!

Note: See TracTickets for help on using tickets.