Opened 5 years ago

Closed 5 years ago

#3852 closed enhancement (duplicate)

Specifing subtitle timing in fast seek mode

Reported by: ghospich Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Motivation:

When burning subtitles in fast seek mode, there is no way to specify subtitle timing. For example.

ffmpeg -ss 102.042 -t 24.250 -i sintel-1024-surround.mp4 -an -c:v libvpx -vf scale=640:-1,subtitles=sintel_en.srt out.webm

That way subs wouldn't be burned into video, because ffmpeg burns them with timing starting from 00:00:00 (there is no phrases in first minutes of video). For some reason in fast seek mode timing not passed to subtitles, and subtitles just simply start from the beginning.

However, in regular slow seek mode everything is fine.

ffmpeg -i sintel-1024-surround.mp4 -ss 102.042 -t 24.250 -an -c:v libvpx -vf scale=640:-1,subtitles=sintel_en.srt out.webm

That way subtitles burned correct, and there is no need in explicitly specifying timing for subtitles.
But slow seek mode is not convenient. There is often a very huge delay before encoding start that way, which is only get worse on huge files.

Enhancement proposal:

I'm not sure why subtitles doesn't timing right in fast seek mode, so i did not opened this issue as 'bug'. If anything, i'll create another issue.

So, maybe add option 'ss' to filter http://ffmpeg.org/ffmpeg-filters.html#subtitles-1 with same function as -ss in ffmpeg itself? This would be simple and convenient workaround.
The ss option would specify from what point ffmpeg should start subtitles, explicitly.

There is already such option in ffmpeg itself, so in 'subtitles' it wouldn't be a foreign.
And with this option it would be finally possible to burn subtitles in fast seek mode.

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from ffmpeg to avfilter
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 2.3 to git-master

Duplicate of ticket #2067.
For future tickets: Please always provide your failing command line together with the complete, uncut console output.

Note: See TracTickets for help on using tickets.