Opened 5 years ago

Closed 5 years ago

#3800 closed defect (fixed)

AVUTIL/BPRINT.H: C++ "error: types may not be defined in 'sizeof' expressions"

Reported by: troy_s Owned by:
Priority: important Component: avutil
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

When using FFMPEG git trunk, C++ mixed code fails on bprint.h with "error: types may not be defined in 'sizeof' expressions"

How to reproduce:

Attempt mixing FFMPEG C code with a C++ application. Tested with g++ 4.6 and 4.8.

In file included from /usr/local/include/libavformat/avio.h:34:0,
                 from /usr/local/include/libavformat/avformat.h:259,
                 from ../YCbCrExporter/ffsequence.h:29,
                 from ../YCbCrExporter/ffsequence.cpp:21:
/usr/local/include/libavutil/bprint.h:78:5: error: types may not be defined in ‘sizeof’ expressions

Change History (8)

comment:1 Changed 5 years ago by cehoyos

  • Keywords regression added; c++ bprint.h removed
  • Priority changed from normal to important

comment:2 Changed 5 years ago by Cigaes

I wonder which one of c++ and ms visual-something compiler is ahead in the game of creating endless problems.
Patch on the mailing list.

comment:3 Changed 5 years ago by jbr

  • Reproduced by developer set

I have reproduced this while trying to build ffms2 master against ffmpeg master.

comment:4 Changed 5 years ago by Cigaes

A patch has been submitted to the devel mailing list and approved, it will land soon in the Git tree.

comment:5 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Nicolas in 04bc3700

comment:6 Changed 5 years ago by cehoyos

  • Resolution fixed deleted
  • Status changed from closed to reopened

I suspect this is reproducible again since f75786f3

comment:7 Changed 5 years ago by Cigaes

Probably. I sent a proposed fix, with a comment to document it.
http://ffmpeg.org/pipermail/ffmpeg-cvslog/2014-August/080270.html

comment:8 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from reopened to closed

Now fixed with a comment.

Note: See TracTickets for help on using tickets.