Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3774 closed enhancement (fixed)

Missing library version information on website

Reported by: projectsymphony Owned by:
Priority: wish Component: documentation
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,
In the download page where stable versions are listed, there is a gray box where all library versions are reported. However it doesn't seem to list libavresample. Could you add it's version there?
Thanks

Change History (14)

comment:1 follow-up: Changed 5 years ago by cehoyos

  • Component changed from undetermined to documentation
  • Priority changed from normal to wish
  • Type changed from defect to enhancement

Please understand that there is nothing unstable about current FFmpeg git head (on the contrary).
I am not sure if it is a good idea to mention libavresample on the download page: It is mostly unmaintained and should not be used.

Last edited 5 years ago by cehoyos (previous) (diff)

comment:2 Changed 5 years ago by projectsymphony

Sorry but I don't understand, if it is not maintained it should be removed, if it is distributed it should be mentioned, or am I missing something?

comment:3 Changed 5 years ago by cehoyos

It is provided for compatibility reasons and cannot be removed.

comment:4 Changed 5 years ago by projectsymphony

Ok so could you mention it? It would make life easier when hunting down for library versions, please.

comment:5 Changed 5 years ago by cehoyos

Did you consider to send a patch yourself?

comment:6 Changed 5 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

avresample is no longer on the (newly revamped) download page. closing ticket...

comment:7 in reply to: ↑ 1 Changed 5 years ago by ubitux

Replying to cehoyos:

Please understand that there is nothing unstable about current FFmpeg git head (on the contrary).
I am not sure if it is a good idea to mention libavresample on the download page: It is mostly unmaintained and should not be used.

Correction here. libavresample is NOT unmaintained. The Libav project maintains it and we merge their changes. BUT, it is unsupported by the FFmpeg project because we have libswresample (since way before libavresample existed) and we use it almost everything. libavresample is less tested in the FFmpeg project.

As a result, we don't really want people to confuse the two and just keep it for compatibility with the Libav project.

But anyway, @projectsymphony, you are probably koda@libav, so I'll assume you are quite aware of this and just wanted to use that ticket as an argument.

comment:8 Changed 5 years ago by compn

oops. you wanted it listed. i see.

the avresample version can be found in apichanges on libav site
http://git.libav.org/?p=libav.git;a=blob;f=doc/APIchanges

or for quick reference

2014-04-xx - xxxxxxx - lavr 1.3.0 - avresample.h

Add avresample_max_output_samples

2014-02-22 - 7e86c27 - lavr 1.2.0 - avresample.h

Add avresample_is_open() for checking whether a resample context is open.

2013-01-07 - 074a00d - lavr 1.1.0

Add avresample_set_channel_mapping() for input channel reordering,
duplication, and silencing.

2012-10-05 - e7ba5b1 - lavr 1.0.0 - avresample.h

Data planes parameters to avresample_convert() and
avresample_read() are now uint8_t instead of void.
Libavresample is now stable.

comment:9 Changed 5 years ago by cehoyos

Since I find this completely non-obvious:
This ticket was indeed created by Vittorio Giovara, avconv developer, and is now apparently used as an argument why avconv is better than FFmpeg.

comment:10 Changed 5 years ago by Timothy_Gu

@cehoyos: can you give a link?

comment:11 Changed 5 years ago by gjdfgh

Why the flying fuck do we need two resample libraries?

Can someone explain this to me?

comment:12 Changed 5 years ago by Timothy_Gu

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This ticket is not fixed. See comment 8.

comment:13 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from reopened to closed

The libavresample versions where missing as the lists where build from the ffmpeg command line output and libavresample is not build, enabled nor used by default, thus also doesnt show up in that case.

Fixed the download page in c9786c88c224e5f7dac1e9d3efc4344aab4093f8

there may be some still missing for the olddownload page, but that is missing other libs as well, improvments for the olddownload page are welcome!

comment:14 Changed 5 years ago by michael

Added missing libavresample versions to olddownloads too (017200dd6a71bfe9b81e8f69492336b4ad04efa2)

Note: See TracTickets for help on using tickets.