Opened 5 years ago

Closed 3 years ago

#3759 closed defect (fixed)

ffmpeg fails to decode empty wav file

Reported by: Sergey Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Get ffmpeg:

$ wget http://ffmpeg.gusari.org/static/32bit/ffmpeg.static.32bit.2014-07-06.tar.gz
$ tar xf ffmpeg.static.32bit.2014-07-06.tar.gz

Create empty file:

$ ./ffmpeg -f s16le -ar 48000 -ac 2 -i /dev/null -acodec copy empty.wav

Fail to open it:

$ ./ffmpeg -i empty.wav 
ffmpeg version N-63893-gc69defd Copyright (c) 2000-2014 the FFmpeg developers
  built on Jul  6 2014 05:13:25 with gcc 4.6 (Debian 4.6.3-1)
  configuration: --prefix=/root/ffmpeg-static/32bit --arch=x86_32 --extra-cflags='-m32 -I/root/ffmpeg-static/32bit/include -static' --extra-ldflags='-m32 -L/root/ffmpeg-static/32bit/lib -static' --extra-libs='-lxml2 -lexpat -lfreetype' --enable-static --disable-shared --disable-ffserver --disable-doc --enable-bzlib --enable-zlib --enable-postproc --enable-runtime-cpudetect --enable-libx264 --enable-gpl --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-gray --enable-libass --enable-libfreetype --enable-libopenjpeg --enable-libspeex --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-version3 --enable-libvpx
  libavutil      52. 89.100 / 52. 89.100
  libavcodec     55. 66.101 / 55. 66.101
  libavformat    55. 43.100 / 55. 43.100
  libavdevice    55. 13.101 / 55. 13.101
  libavfilter     4.  8.100 /  4.  8.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 19.100 /  0. 19.100
  libpostproc    52.  3.100 / 52.  3.100
[wav @ 0xac6f8e0] Estimating duration from bitrate, this may be inaccurate
[wav @ 0xac6f8e0] Could not find codec parameters for stream 0 (Audio: pcm_s16le ([1][0][0][0] / 0x0001), 48000 Hz, 2 channels, 1536 kb/s): unspecified sample format
Consider increasing the value for the 'analyzeduration' and 'probesize' options
empty.wav: could not find codec parameters

May be related to #3746

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added

If there is an issue, it is a regression since 61a84755

comment:2 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.