Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3735 closed defect (fixed)

Compilation fails: oggparsevorbis.c error

Reported by: gerion Owned by:
Priority: important Component: build system
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Compilation of ffmpeg fails with:
libavformat/libavformat.a(oggparsevorbis.o): In function `vorbis_header':
.../libavformat/oggparsevorbis.c:355: undefined reference to `ff_replaygain_export'
How to reproduce:
Use this configure line:
./configure --disable-everything --enable-decoder=h264 --enable-demuxer=matroska --enable-muxer=null --enable-encoder=rawvideo --enable-protocol=file --disable-doc --disable-ffserver --disable-ffplay --disable-ffprobe
and try to build ffmpeg.

Without "--disable-ffserver --disable-ffplay --disable-ffprobe" it works as expected.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open

A patch is currently discussed.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in 97578f5f

comment:3 Changed 5 years ago by gerion

Yep, works for me. Thank you!

Note: See TracTickets for help on using tickets.