Opened 5 years ago

Closed 5 years ago

#350 closed defect (fixed)

Invalid value 'strict' for option 'strict'

Reported by: KSHawkEye Owned by: michael
Priority: normal Component: avcodec
Version: git-master Keywords: -strict
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no


When trying to use strict for option -strict on a Windows FFmpeg build, I'm getting:

[NULL @ 00000000004A5A60] [Eval @ 000000000022F800] Undefined constant or missin
g '(' in 'strict'
[NULL @ 00000000004A5A60] Unable to parse option value "strict"
Invalid value 'strict' for option 'strict'

The input file does not matter, but I tested with h264, aac, and flac to name a few.

This bug should be repeatable with a simple command line:

ffmpeg -i "infile.mp4" -vcodec mpeg4 -an -strict strict "outfile.avi"

using the git-371888c build found here:

I believe

Undefined constant or missing '(' in 'strict'

is the key to this issue, but I could be wrong.

Other values do work, such as "very".

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from FFmpeg to avcodec
  • Priority changed from important to normal
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from git to git-master

I believe this is broken since a very long time (or forever), workaround is to use -strict 1.

comment:2 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

Fixed locally, will push if it passes tests

Note: See TracTickets for help on using tickets.